<!DOCTYPE html>
<!--[if lt IE 7]><html class="no-js lt-ie9 lt-ie8 lt-ie7"  xmlns:fb="https://www.facebook.com/2008/fbml"  xmlns:og="http://ogp.me/ns#" lang="en-US"><![endif]-->
<!--[if IE 7]>	 <html class="no-js lt-ie9 lt-ie8"  xmlns:fb="https://www.facebook.com/2008/fbml"  xmlns:og="http://ogp.me/ns#" lang="en-US"><![endif]-->
<!--[if IE 8]>	 <html class="no-js lt-ie9"  xmlns:fb="https://www.facebook.com/2008/fbml"  xmlns:og="http://ogp.me/ns#" lang="en-US"><![endif]-->
<!--[if gt IE 8]><!--><html class="no-js"  xmlns:fb="https://www.facebook.com/2008/fbml"  xmlns:og="http://ogp.me/ns#" lang="en-US"> <!--<![endif]-->
	<head>
		<meta charset="UTF-8">
		<meta http-equiv="X-UA-Compatible" content="IE=edge,chrome=1">
		<title>Celebrating Prince: Your April guide to events in the Twin Cities |  Local Current Blog | The Current from Minnesota Public Radio</title>
		<link rel="profile" href="http://gmpg.org/xfn/11">
		<link rel="pingback" href="https://blog.thecurrent.org/xmlrpc.php">
		<meta name="viewport" content="width=device-width,initial-scale=1.0" /><meta name="mpr-site" content="the-current" /><meta name="google-site-verification" content="ijWfiDLOyatWKWc_gEImgypgMfpPwoZdnnqYrSTLGJQ" /><meta name="google-site-verification" content="3CVMWxmxyijb333aLKHmJaq6DTYXZ-Hn3loAA49cSK4" />		<link rel="stylesheet" href="//common.publicradio.org/mpr/header/responsive/header.css?8-31-17" />
        <link rel="stylesheet" href="//common.publicradio.org/mpr/footer/responsive/footer.css" />
        <link rel="stylesheet" href="//common.publicradio.org/mpr/header/responsive/header.css?8-31-17" /><link rel="stylesheet" href="//common.publicradio.org/mpr/footer/responsive/footer.css" />                <script>         var _prum = [             ['id', '518d2e7babe53d0168000000'],             ['mark', 'firstbyte', (new Date()).getTime()]         ];         (function() {             var s = document.getElementsByTagName('script')[0],                 p = document.createElement('script');             p.async = 'async';             p.src = '//rum-static.pingdom.net/prum.min.js';             s.parentNode.insertBefore(p, s);         })();     </script>        <link rel="shortcut icon" href="https://kyigt1bcans3ofli94di0kch-wpengine.netdna-ssl.com/wp-content/themes/thecurrent/images/favicon.ico" type="image/x-icon" />
        <link rel="apple-touch-icon" href="https://kyigt1bcans3ofli94di0kch-wpengine.netdna-ssl.com/wp-content/themes/thecurrent/images/touch-icon-iphone.png" />
        <link rel="apple-touch-icon" sizes="72x72" href="https://kyigt1bcans3ofli94di0kch-wpengine.netdna-ssl.com/wp-content/themes/thecurrent/images/touch-icon-ipad.png" />
        <link rel="apple-touch-icon" sizes="114x114" href="https://kyigt1bcans3ofli94di0kch-wpengine.netdna-ssl.com/wp-content/themes/thecurrent/images/touch-icon-iphone4.png" />
<!-- , , ,  -->
		    
 
<meta property="og:title" content="Celebrating Prince: Your April guide to events in the Twin Cities">

<meta property="og:description" content="">
<meta name="description" content="">

<meta property="og:url" content="https://blog.thecurrent.org/2019/03/celebrating-prince-your-april-guide-to-events-in-the-twin-cities/">

<meta name="author" content="Marla Khan-Schwartz">

<meta property="og:image" content="https://blog.thecurrent.org/wp-content/blogs.dir/9/files/2018/02/180202_NPG_003.jpg">
<meta property="og:type" content="article">
<meta property="og:site_name" content="Local Current Blog | The Current from Minnesota Public Radio">


	
<meta name="mpr-collection" content="Contributors">
<meta name="WT.cg_n" content="The Current: Contributors">


<meta name="mpr-content-group" content="blog"><link rel='dns-prefetch' href='//s.w.org' />
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/11\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/11\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/blog.thecurrent.org\/wp-includes\/js\/wp-emoji-release.min.js"}};
			!function(a,b,c){function d(a,b){var c=String.fromCharCode;l.clearRect(0,0,k.width,k.height),l.fillText(c.apply(this,a),0,0);var d=k.toDataURL();l.clearRect(0,0,k.width,k.height),l.fillText(c.apply(this,b),0,0);var e=k.toDataURL();return d===e}function e(a){var b;if(!l||!l.fillText)return!1;switch(l.textBaseline="top",l.font="600 32px Arial",a){case"flag":return!(b=d([55356,56826,55356,56819],[55356,56826,8203,55356,56819]))&&(b=d([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]),!b);case"emoji":return b=d([55358,56760,9792,65039],[55358,56760,8203,9792,65039]),!b}return!1}function f(a){var c=b.createElement("script");c.src=a,c.defer=c.type="text/javascript",b.getElementsByTagName("head")[0].appendChild(c)}var g,h,i,j,k=b.createElement("canvas"),l=k.getContext&&k.getContext("2d");for(j=Array("flag","emoji"),c.supports={everything:!0,everythingExceptFlag:!0},i=0;i<j.length;i++)c.supports[j[i]]=e(j[i]),c.supports.everything=c.supports.everything&&c.supports[j[i]],"flag"!==j[i]&&(c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&c.supports[j[i]]);c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&!c.supports.flag,c.DOMReady=!1,c.readyCallback=function(){c.DOMReady=!0},c.supports.everything||(h=function(){c.readyCallback()},b.addEventListener?(b.addEventListener("DOMContentLoaded",h,!1),a.addEventListener("load",h,!1)):(a.attachEvent("onload",h),b.attachEvent("onreadystatechange",function(){"complete"===b.readyState&&c.readyCallback()})),g=c.source||{},g.concatemoji?f(g.concatemoji):g.wpemoji&&g.twemoji&&(f(g.twemoji),f(g.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
<link rel='stylesheet' id='foundation-css'  href='https://kyigt1bcans3ofli94di0kch-wpengine.netdna-ssl.com/wp-content/themes/thecurrent/styles/foundation.min.css' type='text/css' media='all' />
<link rel='stylesheet' id='thecurrent-style-css'  href='https://kyigt1bcans3ofli94di0kch-wpengine.netdna-ssl.com/wp-content/themes/thecurrent/styles/current-style.css' type='text/css' media='all' />
<link rel='stylesheet' id='thecurrent-blog-less-css'  href='https://kyigt1bcans3ofli94di0kch-wpengine.netdna-ssl.com/wp-content/themes/thecurrent/styles/current-less.css' type='text/css' media='all' />
<script type='text/javascript' src='https://kyigt1bcans3ofli94di0kch-wpengine.netdna-ssl.com/wp-includes/js/jquery/jquery.js?ver=1.12.4'></script>
<script type='text/javascript' src='https://kyigt1bcans3ofli94di0kch-wpengine.netdna-ssl.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=1.4.1'></script>
<link rel='https://api.w.org/' href='https://blog.thecurrent.org/wp-json/' />
<link rel="canonical" href="https://blog.thecurrent.org/2019/03/celebrating-prince-your-april-guide-to-events-in-the-twin-cities/" />
<link rel='shortlink' href='https://blog.thecurrent.org/?p=36492' />
<link rel="alternate" type="application/json+oembed" href="https://blog.thecurrent.org/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fblog.thecurrent.org%2F2019%2F03%2Fcelebrating-prince-your-april-guide-to-events-in-the-twin-cities%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://blog.thecurrent.org/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fblog.thecurrent.org%2F2019%2F03%2Fcelebrating-prince-your-april-guide-to-events-in-the-twin-cities%2F&#038;format=xml" />
<link rel="sitemap" href="https://blog.thecurrent.org/sitemap.xml" />
</head>
	<body class="post-template-default single single-post postid-36492 single-format-standard">

        <noscript data-component="google-tag-manager"><iframe src="//www.googletagmanager.com/ns.html?id=GTM-48R7" height="0" width="0" style="display:none;visibility:hidden"></iframe></noscript><script data-component="google-tag-manager">         (function(w, d, s, l, i) {             w[l] = w[l] || [];             w[l].push({                 'gtm.start': new Date().getTime(),                 event: 'gtm.js'             });             var f = d.getElementsByTagName(s)[0],                 j = d.createElement(s),                 dl = l != 'dataLayer' ? '&l=' + l : '';             j.async = true;             j.src =                 '//www.googletagmanager.com/gtm.js?id=' + i + dl;             f.parentNode.insertBefore(j, f);         })(window, document, 'script', 'dataLayer', 'GTM-48R7');     </script>	<header id="MPResponsiveHeaderBand">         <nav id="headerTop">             <ul id="mainNav" class="collapse" title="Stations">                 <li class="mpr"><a title="Minnesota Public Radio" href="http://minnesota.publicradio.org/"><b>Minnesota Public Radio</b></a></li>                 <li><span class="collapsedName"><b>Stations</b></span>                     <ul>                         <header class="nav-mobile-header">                             <div class="nav-cancelbutton">Cancel</div>                             <div style="clear:both;"></div>                         </header>                         <li class="news"><a title="Minnesota Public Radio News" href="http://www.mprnews.org/"><span class="station-title">News</span><span class="mobile-title">MPR News <span>mprnews.org</span></span></a></li>                         <li class="current"><a title="The Current from Minnesota Public Radio" href="http://www.thecurrent.org/"><span class="station-title">The Current</span><span class="mobile-title">The Current <span>thecurrent.org</span></span></a></li>                         <li class="classical"><a title="Classical Minnesota Public Radio" href="http://minnesota.publicradio.org/radio/services/cms/"><span class="station-title">Classical</span><span class="mobile-title">Classical MPR <span>classicalmpr.org</span></span></a></li>                         <li class="nav-mpr"><a title="Minnesota Public Radio" href="http://minnesota.publicradio.org/"><span class="mobile-title">Minnesota Public Radio<span>mpr.org</span></span></a></li>                     </ul>                 </li>             </ul>             <div id="rightNav">                 <ul id="secondaryNav" class="collapse" title="">                     <li><span class="collapsedName"><b>MPR Information</b></span>                         <div>                             <header class="nav-mobile-header">                                 <div class="nav-headertitle">MPR Information</div>                                 <div class="nav-cancelbutton">Cancel</div>                                 <div style="clear:both;"></div>                             </header>                             <ul id="secondaryNavWrapper">                                 <li class="nav-give-mobile"><a href="https://contribute.publicradio.org/contribute.php?refId=current&&utm_medium=web_header_dropdown&utm_source=current&utm_content=&utm_term" class="giveNowHeaderLink">Give Now</a></li>                                 <li><a href="http://archive.mprnews.org">Archive</a></li>                                 <li><a class="withSub" href="http://minnesota.publicradio.org/events/">Events</a>                                     <div class="eventsSub">                                         <ul>                                             <li class="first"><a href="http://minnesota.publicradio.org/events/tickets/">Tickets</a></li>                                             <li><a href="http://minnesota.publicradio.org/events/">Events Calendar</a></li>                                             <li><a href="http://minnesota.publicradio.org/support/travel/">MPR Custom Travel</a></li>                                         </ul>                                     </div>                                 </li>                                 <li><a href="http://minnesota.publicradio.org/support/shop/">Shop</a></li>                                 <li><a class="withSub" href="http://minnesota.publicradio.org/about/">About us</a>                                     <div id="aboutSub">                                         <ul>                                             <li class="first"><a href="http://www.thecurrent.org/radio_heartland/">Radio Heartland</a></li>                                             <li><a href="http://www.thecurrent.org/wonderground/">Wonderground Radio</a></li>                                             <li><a href="http://minnesota.publicradio.org/about/mpr/">Company Information</a></li>                                             <li><a href="http://minnesota.publicradio.org/radio/stations/">Stations</a></li>                                             <li><a href="http://minnesota.publicradio.org/publicinsightjournalism/">Public Insight Journalism</a></li>                                             <li><a href="http://minnesota.publicradio.org/about/contact/">Contact Info</a></li>                                             <li><a href="http://minnesota.publicradio.org/about/press/">Press Room</a></li>                                             <li><a href="http://minnesota.publicradio.org/about/people/">MPR People</a></li>                                             <li><a href="http://americanpublicmedia.publicradio.org/careers/">Career Opportunities</a></li>                                             <li><a href="http://minnesota.publicradio.org/about/partners/">Partners</a></li>                                             <li><a href="http://minnesota.publicradio.org/about/educational_sponsors/">Educational Sponsors</a></li>                                             <li><a href="http://mn4mpr.org/">Minnesotans for MPR</a></li>                                             <li><a href="http://minnesota.publicradio.org/about/tapes/">Tapes &amp; Transcripts</a></li>                                             <li><a href="http://minnesota.publicradio.org/about/towers/">Tower Rental</a></li>                                         </ul>                                     </div>                                 </li>                                 <li><a class="withSub" href="http://minnesota.publicradio.org/support/">Members</a>                                     <div id="supportSub">                                         <ul>                                             <li class="first"><a href="http://minnesota.publicradio.org/support/member_benefits/">Member Benefits</a></li>                                             <li><a href="http://minnesota.publicradio.org/support/membership/sustaining_members.shtml">Sustaining Membership</a></li>                                             <li><a href="http://minnesota.publicradio.org/support/more-ways-to-give/">More Ways to Give</a></li>                                             <li><a href="http://minnesota.publicradio.org/about/contact/">Contact Us</a></li>                                             <li><a class="giveNowHeaderLink" href="https://contribute.publicradio.org/contribute.php?refId=current&&utm_medium=web_header_dropdown&utm_source=current&utm_content=&utm_term">Become a Member</a></li>                                         </ul>                                     </div>                                 </li>                                 <li class="nav-give nav-give-title"><a href="https://contribute.publicradio.org/contribute.php?refId=current&utm_medium=web_nav_button&utm_source=current&utm_content=&utm_term" class="giveNowHeaderLink">Give Now</a></li>                             </ul>                         </div>                     </li>                 </ul>                 <form class="search-form" action="//www.mpr.org/search" method="get" name='search' id="searchForm"> <span class="collapsedName"></span>                     <div class="nav-search">                         <header class="nav-mobile-header">                             <div class="nav-headertitle">Search MPR</div>                             <div class="nav-cancelbutton">Cancel</div>                             <div style="clear:both;"></div>                         </header> <input name="site" value="mpr" type="hidden"> <input name="client" value="mpr" type="hidden"> <input name="ie" value="UTF-8" type="hidden"> <input name="oe" value="UTF-8" type="hidden"> <input name="output" value="xml" type="hidden"> <input name="entqr" value="3" type="hidden"> <input name="filter" value="p" type="hidden"> <input name="numgm" value="5" type="hidden"> <input name="access" value="p" type="hidden"> <input name="start" value="0" type="hidden"> <input name="num" value="10" type="hidden"> <input class='searchbox empty' name="q" placeholder="Search MPR" type="text"> </div>                 </form>             </div>         </nav>     </header>
	<div id="container">
<div class="row" id="theCurrent">

	<header class="four columns navRail">                 <nav id="logoWrapper"> <a id="logo" href="http://old.thecurrent.org/"><span class="visuallyhidden">The Current</span></a> <a href="https://contribute.publicradio.org/contribute.php?refId=current&utm_campaign=membership_contribution&utm_medium=web_header_button&utm_source=current&utm_content=&utm_term" id="giveNow">Listener Supported &middot; <span>Give now</span> &rsaquo;</a> </nav> <a href="http://old.thecurrent.org/listen" id="listenLive" target="player" class="player-open">Listen Live <span></span></a> <a href="https://www.thecurrent.org/request" id="requestSong"><b>Request a song</b> <span></span></a>                 <a id="skip" href="#pjaxReplaceTarget" title="Skip to content" class="screen-reader-text"></a>                 <nav id="headerNavWrapper">                     <ul id="headerNav">                         <li id='streams'>                             <h3><a name="streams"><span>More </span>Streams</a></h3>                             <div class="inner" data-parent="#streams">                                 <ol id="streamsSub" class='subNav'>                                     <li>                                         <h5><a href="http://www.thecurrent.org/local">Local Current</a></h5>                                         <p>                                             Minnesota Music<br /> <a href="http://www.thecurrent.org/listen/local" target="player" class="listen player-open">Listen Live <span></span></a> <a href="http://blog.thecurrent.org" class='blog'>Blog &rsaquo;</a> </p>                                     </li>                                     <li>                                         <h5><a href="http://www.thecurrent.org/rock-the-cradle">Rock The Cradle</a></h5>                                         <p>                                             Music for kids and their adults<br /> <a href="http://www.thecurrent.org/listen/rock-the-cradle" target="player" class="listen player-open">Listen Live <span></span></a> </p>                                     </li>                                     <li>                                         <h5><a href="http://www.thecurrent.org/heartland">Radio Heartland</a></h5>                                         <p>                                             Acoustic, Americana and Roots<br /> <a href="http://www.thecurrent.org/listen/heartland" target="player" class="listen player-open">Listen Live <span></span></a> </p>                                     </li> 																		<li>                                         <h5><a href="http://www.thecurrent.org/purple-current">Purple Current</a></h5>                                         <p>                                             Exploring the musical legacy of Prince and beyond<br /> <a href="http://www.thecurrent.org/listen/purple-current" target="player" class="listen player-open">Listen Live <span></span></a> </p>                                     </li>                                 </ol>                             </div>                         </li><li id='about'>                             <h3><a href="http://old.thecurrent.org/about">About</a></h3>                             <div class="inner" data-parent="#about">                                 <ul id='aboutSub' class='subNav'>                                     <li><a href="http://www.thecurrent.org/about">About</a></li>                                     <li><a href="http://www.thecurrent.org/about#where-to-hear">Where to hear</a></li>                                     <li><a href="http://www.thecurrent.org/about/mobile">Mobile apps</a></li>                                     <li><a href="http://www.thecurrent.org/programs">Programs</a></li>                                     <li><a href="http://www.thecurrent.org/about#hosts">Hosts</a></li>                                     <li><a href="http://www.thecurrent.org/about#music">Submit Your Music</a></li>                                     <li><a href="http://www.prettygoodgoods.org/categories/12931-the-current">Shop</a></li>                                     <li class="spacer"></li>                                     <li><a href="https://www.facebook.com/TheCurrent">Facebook</a></li>                                     <li><a href="https://plus.google.com/104446135620282090978/posts">Google+</a></li>                                     <li><a href="http://instagram.com/thecurrent">Instagram</a></li>                                     <li><a href="http://893thecurrent.tumblr.com">Tumblr</a></li>                                     <li><a href="https://twitter.com/TheCurrent">Twitter</a></li>                                     <li><a href="http://www.youtube.com/user/893TheCurrent?sub_confirmation=1">YouTube</a></li>                                 </ul>                             </div>                         </li>                     </ul>                 </nav>                 <div id="navDrops"></div>             </header>
	<div id="pjaxReplaceTarget" role="main">
	    <div class="twelve columns contentRail detail leaderboard adaptTarget adaptWide" data-adapt="leaderboard">                     <div class="advertisement wider adaptSource" data-adapt="leaderboard">                         <div class="ad" id="mpr-ad-leader"></div>                     </div>                 </div>	    <div class="twelve columns contentRail detail">
    	    <header class="localBlog">
	<h1><a href="https://blog.thecurrent.org">Local Current Blog</a></h1>
</header>
    	    <section class="content">
				

	<article class='entry-content'>
	    <header>
	       <h1>Celebrating Prince: Your April guide to events in the Twin Cities</h1>
	    </header>

          <div class="row">
              <div class="byline eight columns">
                  by <span class="author">Marla Khan-Schwartz</span> &middot;

                  <a href="https://blog.thecurrent.org/2019/03/28/" title="View more posts from March 28, 2019">
                      <time datetime="2019-03-28T10:16:36-05:00">March 28, 2019</time>
                  </a>
                </div>

              <div class="taxonomies eight columns">
                  <span class="tags"></span>
                  <span class="topics"><a href="https://blog.thecurrent.org/music-topics/prince/" rel="tag">Prince</a></span>
                  <span class="categories"><a href="https://blog.thecurrent.org/category/contributors/" rel="tag">Contributors</a></span>
                  <span class="comments_number"><span class="dsq-postid" data-dsqidentifier="36492 http://blog.thecurrent.org/?p=36492"><a href="#comments" class="no-comments">Add a comment</a></span></span>
              </div>
          </div>

		    		            		    <figure id="primaryImage" class="">

                    
<span class="responsiveImage attachment-large size-large wp-post-image " alt="" title=""
 data-media="https://kyigt1bcans3ofli94di0kch-wpengine.netdna-ssl.com/wp-content/blogs.dir/9/files/2018/02/180202_NPG_003-120x120.jpg" 

 data-media602="https://kyigt1bcans3ofli94di0kch-wpengine.netdna-ssl.com/wp-content/blogs.dir/9/files/2018/02/180202_NPG_003-602x401.jpg" 

 data-media768="https://kyigt1bcans3ofli94di0kch-wpengine.netdna-ssl.com/wp-content/blogs.dir/9/files/2018/02/180202_NPG_003-768x512.jpg" 

 data-media630="https://kyigt1bcans3ofli94di0kch-wpengine.netdna-ssl.com/wp-content/blogs.dir/9/files/2018/02/180202_NPG_003-630x420.jpg" 

 data-media300="https://kyigt1bcans3ofli94di0kch-wpengine.netdna-ssl.com/wp-content/blogs.dir/9/files/2018/02/180202_NPG_003-300x200.jpg" 

 data-media600="https://kyigt1bcans3ofli94di0kch-wpengine.netdna-ssl.com/wp-content/blogs.dir/9/files/2018/02/180202_NPG_003-600x400.jpg" 

 data-media630="https://kyigt1bcans3ofli94di0kch-wpengine.netdna-ssl.com/wp-content/blogs.dir/9/files/2018/02/180202_NPG_003-630x420.jpg" 

 data-media1200="https://kyigt1bcans3ofli94di0kch-wpengine.netdna-ssl.com/wp-content/blogs.dir/9/files/2018/02/180202_NPG_003.jpg" 

 data-media738="https://kyigt1bcans3ofli94di0kch-wpengine.netdna-ssl.com/wp-content/blogs.dir/9/files/2018/02/180202_NPG_003-738x492.jpg" 

 data-media1200="https://kyigt1bcans3ofli94di0kch-wpengine.netdna-ssl.com/wp-content/blogs.dir/9/files/2018/02/180202_NPG_003.jpg" 
> <noscript> <img src="https://kyigt1bcans3ofli94di0kch-wpengine.netdna-ssl.com/wp-content/blogs.dir/9/files/2018/02/180202_NPG_003.jpg" alt="" title="" width="630" height="420" class="attachment-large size-large wp-post-image" itemprop="image"/> </noscript></span>

                    <figcaption>
                        The New Power Generation perform at the Dakota, 2018. (Emmet Kowler for MPR)                    </figcaption>
            	</figure>
        
          <aside id="featureAds" class="advertisements adaptTarget adaptWide" data-adapt="featureAds">
            <div class='adaptSource'>
            <ul>
            <li class="advertisement">
                <h5>Sponsor</h5>
                <div class="ad multi" id="mpr-ad-1"></div>
            </li>
            <li class="advertisement">
                <h5>Sponsor</h5>
                <div class="ad" id="mpr-ad-2"></div>
            </li>
            </ul>
            </div>
        </aside>
		    <p>Looking for ways to celebrate the life of Prince in April? Here is a list of local events around the Twin Cities.</p> <h4>Prince Family Dance Party 2019</h4> <p>Saturday, April 20<br /> Excelsior Brewing Company, Excelsior<br /> 11 a.m., free</p> <p>This second annual Prince event has everything you need to celebrate, including a <em>Purple-Rain-</em>inspired soda. Dance the afternoon away with the family while enjoying food vendors and face painting. Once the kids are in bed, come back at 8 p.m. for a Prince Tribute party featuring Jacuzzi Puma. Donations accepted on behalf of <a href="https://blog.thecurrent.org/2018/07/princes-philanthropic-legacy-lives-on-through-prn-alumni-and-purple-playground/">Purple Playground</a>.</p> <p>More information about this event <a href="http://excelsiorbrew.com/prince-family-dance-party-2019/">here.</a></p> <h4>Prince Tribute Crawl (2nd Annual)</h4> <p>Saturday, April 20<br /> 508 Bar, Minneapolis<br /> 4 p.m., $10-$25, 21+</p> <p>If you want to get some steps in while honoring the Purple One, you may want to join this pub crawl. Participating bars plan to create Prince-themed cocktails as well as provide live entertainment. A ticket purchase allows free cover to all of the venues. Profits go to local charities.</p> <p>Tickets and information <a href="https://www.facebook.com/events/385895592210724/">here.</a></p> <h4>Dearly Beloved: Join us for a Prince Tribute</h4> <p>Saturday, April 20<br /> Pinot’s Palette, St. Louis Park<br /> 7 p.m., $38</p> <p>Get ready to paint the evening purple while rocking out to Prince. Local artists will help you paint a purple masterpiece while you perhaps sip on a glass of wine. Purple attire recommended.</p> <p>Tickets and information<a href="https://www.pinotspalette.com/stlouispark/event/312727"> here.</a></p> <h4><em>Purple Rain</em> (1984): 35mm Presentation</h4> <p>Sunday, April 21<br /> The Parkway Theater, Minneapolis<br /> 4 p.m./7:30 p.m., $9</p> <p>Relive the nostalgia of seeing <em>Purple Rain</em> in 35mm, just like it was presented to eager audiences in 1984. Sip on an originally crafted and movie-inspired cocktail by the Parkway’s mixologist, and soak up the movie’s everlasting influences.</p> <p>Tickets and more information<a href="https://theparkwaytheater.com/all-events/purple-rain"> here.</a></p> <p><a href="https://gph.is/2LjfZpJ"><img src="https://media.giphy.com/media/6IhO2yo4BbOBg2nRJN/giphy.gif" alt="Purple Rain Prince GIF by The Revolution - Find &amp; Share on GIPHY" width="480" height="270" /></a></p> <h4>Prince Sip and Paint Party</h4> <p>Sunday, April 21<br /> Creative Hearts MN and Glow 808, St. Paul<br /> 5 p.m., $45/$60</p> <p>Paint your very own portrait of Prince while listening to a live D.J. inspire you with Prince’s vast catalog of music. Sip on a signature drink, and play Prince trivia while you paint the night away.</p> <p>Tickets and more information <a href="https://www.eventbrite.com/e/prince-sip-and-paint-party-tickets-57666962437?aff=ebdssbdestsearch">here.</a></p> <h4>Prince Legacy Tours at the Capri</h4> <p>April 22-25<br /> Capri Theater, Minneapolis<br /> Times Vary, $20</p> <p>Check out the original theater where it all began: from photos of <a href="https://blog.thecurrent.org/2014/01/then-and-now-the-capri-theater-where-prince-played-his-first-solo-show/">Prince’s first 1979 gig</a> to an intimate tour of the Capri, this informative experience is a must before the new theater opens in 2020.</p> <p>Tickets and more information <a href="https://thecapritheater.org/prince-legacy-tours-2019/">here.</a></p> <h4>The Paisley 5&amp;Dime Presents: Celebration 2019 Kickoff Party at Gluek’s</h4> <p>Wednesday, April 24<br /> Gluek’s Restaurant and Bar, Minneapolis<br /> 6 p.m., $31.21</p> <p>Enjoy an evening of music and laughter while listening to the comedy of Travis Thurman and Jessica Rivera live on stage at Gluek’s. Join DJ SPooKY, DJ DLP, and DJ Nevermind to celebrate 25 years since the release of <em>The Black Album.</em> Ticket holders will also have an opportunity to participate in a special authors spotlight event earlier that day that includes thoughts from The Current’s Andrea Swensson on her book <em>Got to Be Something Here.</em></p> <p>Tickets and more information <a href="https://www.eventbrite.com/e/the-paisley-5-dime-presents-celebration-2019-kickoff-party-at-glueks-tickets-45020388193?aff=ebdssbdestsearch">here.</a></p> <h4>Starr Party II</h4> <p>Wednesday, April 24<br /> The Pourhouse, Minneapolis<br /> 8 p.m., $20, 21+</p> <p>Celebrate with the Prince community by enjoying an evening of dancing, free henna and free hugs. The second annual event will feature music from DJ Hightop (aka Alphonso Starr), and vocals from Martin Kember.</p> <p>Tickets and more information <a href="https://thepourhousempls.com/event/starr-party-ii/">here.</a></p> <h4>Sound 80 Studio Tours</h4> <p>Wednesday, April 24 and Monday, April 29<br /> Orfield Lab, Minneapolis<br /> Times vary, $20</p> <p>Minneapolis music historian Kristen Zschomler leads tours of the famed studio where Prince recorded his demos, and where Bob Dylan recorded much of <em>Blood on the Tracks</em>.</p> <p>Tickets and more information <a href="https://www.eventbrite.com/e/sound-80-studio-tour-dylan-digital-punk-and-a-young-prince-tickets-59076429190?aff=utm_source%3Deb_email%26utm_medium%3Demail%26utm_campaign%3Dnew_event_email&amp;utm_term=eventurl_text">here</a>.</p> <h4>The Jellybean Johnson Experience Presents Nothing Compares 2P</h4> <p>Thursday, April 25<br /> Minnesota Music Cafe, St. Paul<br /> 7 p.m., $20</p> <p>Join original Prince band member Jellybean Johnson, as he plays music throughout the evening at this event that features many local bands celebrating not only the life of Prince, but Minnesota music. Bands include iLLism, Seismic City, Corey Medina and Brothers, the Smitty Pit, L*A*W* and the Planet 12 Movement, as well as many other special guests.</p> <p>Tickets and information <a href="https://www.eventbrite.com/e/the-jellybean-johnson-experience-presents-nothing-compares-2-p-tickets-55996798933?aff=ebdssbdestsearch">here.</a></p> <h4>Prince 365 Party After the Park</h4> <p>Thursday, April 25<br /> 508 Bar and Restaurant, Minneapolis<br /> 9 p.m., $22, 21+</p> <p>If you are looking for an event where you may hear more than just the hits, join DJ Lenka Paris and Peter Bravestrong for a night of dancing and giveaways.</p> <p>Tickets and more information <a href="https://www.eventbrite.com/e/prince-365-party-after-the-park-tickets-54241292165?aff=ebdssbdestsearch">here.</a></p> <h4>Celebration 2019</h4> <p>Paisley Park, Chanhassen<br /> April 25-28, Ticket prices vary, per event</p> <p>Join former Prince collaborators and friends for a four-day celebration at Paisley Park. Events will include live music, panel discussions, and unique presentations about the prolific artist&#8217;s life and legacy. Several different ticket types are available and depending on which package you choose, it may include entrance to the <em>Prince: In Concert on the Big Screen</em> event at The Armory. Panelists, performers and speakers include Jesse Z, The Revolution, Funk Soldiers, as well as many others who are eager to share this special event with the public.</p> <p>Tickets and more information<a href="https://officialpaisleypark.com/pages/celebration-2019"> here.</a></p> <h4>Prince: In Concert and on the Big Screen, presented by Paisley Park</h4> <p>Friday, April 26<br /> The Armory, Minneapolis<br /> 8 p.m., $65 and up, All Ages</p> <p>This not-to-be missed event will feature newly remastered and never-before-released audio and video of Prince. An all-star ensemble of musicians who once performed with Prince will accompany the audio and video live on stage. The experience will showcase Prince’s sound and the unique energy that he brought to his audience.</p> <p>Tickets and more information<a href="https://www.thecurrent.org/events/2019/04/26/4931/prince-in-concert-on-the-big-screen"> here.</a></p> <h4>Prince 365 Purple Perkins Pancakes Late Night Part Deux</h4> <p>April 26-27<br /> Perkins Restaurants, Chanhassen<br /> 11 p.m. to 6 a.m., $7</p> <p>If you have a case of the late-night munchies, you may consider indulging in some purple pancakes while listening to live DJ Brother Jules at this family-friendly restaurant that sits close to Paisley Park.</p> <p>Tickets and more information <a href="https://www.eventbrite.com/e/prince-365-purple-perkins-pancakes-late-night-part-deux-tickets-54249160700?aff=ebdssbdestsearch">here.</a></p> <h4>Prince Rooftop Celebration: A Purple Dance Party</h4> <p>Friday, April 26<br /> Union Rooftop, Minneapolis<br /> 10 p.m., Tickets available soon, 21+</p> <p>A former Prince DJ, Larry Peace will help celebrate the Purple One by spinning some deep cuts, old school classics and hits. Presented by Flip Phone, this event will certainly help you relive some of your greatest dance moves and grooves.</p> <p>Tickets and more information<a href="http://unionmpls.com"> here.</a></p> <h4>Prince Drag Brunch</h4> <p>Saturday, April 27<br /> Union Rooftop, Minneapolis<br /> 10a.m./12:30p.m., $12</p> <p>Starring Vincent the Destroyer, Damien D’Luxe, and Cee Russell, buy your tickets to attend the infamous Union Rooftop drag brunch. Gussy up in your best purple attire and get ready to rock out while dining on the Union’s weekend menu.</p> <p>Tickets and more information<a href="http://unionmpls.com"> here.</a></p> <h4>The New Power Generation: Tribute to Prince’s Legacy</h4> <p>Saturday, April 27<br /> The Fine Line Music Cafe<br /> 11 p.m., $50/$75/$175, 21+</p> <p>Once labeled by Prince as his “best band ever,” <a href="https://blog.thecurrent.org/2016/06/new-power-generation-the-story-of-princes-90s-band/">the New Power Generation</a> will pay tribute to their iconic mentor at a late-night event packed with music. NPG not only have plans to play music from their time with Prince, but hits from all stages of Prince’s career.</p> <p>Tickets and more information<a href="http://event.etix.com/ticket/online/performanceSale.do?performance_id=4888480&amp;partner_id=240&amp;method=restoreToken&amp;cobrand=FineLine"> here.</a></p> <div class="flex-video oembed-youtu"><iframe width="500" height="375" src="https://www.youtube.com/embed/hwUKR_9Xdns?feature=oembed" frameborder="0" allow="accelerometer; autoplay; encrypted-media; gyroscope; picture-in-picture" allowfullscreen></iframe></div> <h4>Love 2 the 9’s</h4> <p>Saturday, April 27<br /> The Parkway Theater, Minneapolis<br /> 11 p.m., $55/$65</p> <p>Join Prince’s longtime keyboardist Tommy Barbarella on the grand piano, accompanied by vocalist Julius Collins for an evening of music and storytelling about the life and legacy of Prince. Along with Petar Janic on percussion and Jeremy Ylvisaker on guitar, this late-night acoustic set will be played against an intimate backdrop. The Parkway’s mixologist will also have a Prince-inspired cocktail to sip on while taking in the ambiance.</p> <p>Tickets and more information <a href="https://theparkwaytheater.com/all-events/love-2-the-9s">here.</a></p> <table style="width:100%;"> <tr> <td colspan="3"> <h4>Stream Purple Current</h4> <p><audio src="//purplecurrent.stream.publicradio.org/purplecurrent.mp3" controls /></td> </tr> <tr> <td colspan="3">Get the latest stories about Prince&#8217;s musical legacy and updates on what&#8217;s playing on <a href="http://purplecurrent.org">Purple Current</a>. </td> </tr> <tr> <form action="https://mcpostman.publicradio.org/subscription_requests" class="mcpostman-form" method="post"> <td width="25%" style="vertical-align:middle;"><a href="http://purplecurrent.org"><img src="https://img.apmcdn.org/52e71ea8216bfb688e9408ccfad6b937bd6d22d6/square/08d203-20180402-purple-current-white-sq.jpg" alt="Purple Current" style="width:100%;" /></a></td> <td width="55%" style="vertical-align:middle;"><input name="subscription_request[property_key]" type="hidden" value="4d65beaf-c409-44b3-9637-0cab7a02db00" />  <input name="subscription_request[sde_external_key]" type="hidden" value="" />  <input name="subscription_request[fsm][Form_BusinessUnit]" type="hidden" value="MPR" />  <input name="subscription_request[fsm][Form_FormName]" type="hidden" value="Current_PurpleCurrentSubscribe_Form" />  <input name="subscription_request[fsm][Form_Opt_In_Source]" type="hidden" value="MPR Current Newsletter" />  </p> <div class="form-group">    <label for="subscription_request_fsm_Form_Email_Address">Email Address <span class="required-marker">*</span></label>    <input type="email" name="subscription_request[fsm][Form_Email_Address]" id="subscription_request_fsm_Form_Email_Address" required="required" maxlength="254" class="form-control" />  </div> </td> <td width="20%" style="vertical-align:middle;"><input name="subscription_request[publication_lists][1043]" type="hidden" value="on" />  <button class="button" type="submit">Sign up</button></td> </tr> </form> </table> 
            

          <div id="socialShare" class="hide-on-mobile">
        <!-- facebook devilspawn -->
        <div class="fbLikeWrapper">
        <div class="fb-like" data-href="https://blog.thecurrent.org/2019/03/celebrating-prince-your-april-guide-to-events-in-the-twin-cities/" data-send="false" data-layout="button_count" data-width="100" data-show-faces="false" data-colorscheme="light"></div>
        </div>
        <!-- twitter tweet button -->
    <a href="https://twitter.com/share" class="twitter-share-button" data-via="TheCurrent" id='twitterShareButton'>Tweet</a>
    <script>
        var tElem = document.getElementById('twitterShareButton');
            if (tElem.offsetWidth !== 0 && tElem.offsetHeight !== 0){
                ! function (d, s, id) {
                    var js, fjs = d.getElementsByTagName(s)[0];
                    if (!d.getElementById(id)) {
                        js = d.createElement(s);
                        js.id = id;
                        js.src = "//platform.twitter.com/widgets.js";
                        fjs.parentNode.insertBefore(js, fjs);
                    }
                }(document, "script", "twitter-wjs");
            }
        </script>

        <g:plusone></g:plusone>
        <script type="text/javascript">
            window.___gcfg = {
            lang: 'en-US'
            };

            (function() {
            //even tho this is g+, we key in on twitter elem because this uses the weird g: namespaced elements that are not yet init'd
            var tElem = document.getElementById('twitterShareButton');
          if (tElem.offsetWidth !== 0 && tElem.offsetHeight !== 0){    
                var po = document.createElement('script'); po.type = 'text/javascript'; po.async = true;
                po.src = 'https://apis.google.com/js/plusone.js';
                var s = document.getElementsByTagName('script')[0]; s.parentNode.insertBefore(po, s);
            }
            })();
        </script>
        
          <script data-component="facebook">
           if (jQuery('.fb-like:visible').length){
               (function(d, s, id) {
                var js, fjs = d.getElementsByTagName(s)[0];
                if (d.getElementById(id)) return;
                js = d.createElement(s); js.id = id;
                js.src = "//connect.facebook.net/en_US/all.js#xfbml=1&appId=115904101776300";
                fjs.parentNode.insertBefore(js, fjs);
              }(document, 'script', 'facebook-jssdk'));
            }
          </script>

        <a href="http://pinterest.com/pin/create/button/?url=https%3A%2F%2Fblog.thecurrent.org%2F2019%2F03%2Fcelebrating-prince-your-april-guide-to-events-in-the-twin-cities%2F&media=&description=Celebrating+Prince%3A+Your+April+guide+to+events+in+the+Twin+Cities" class="pin-it-button" count-layout="horizontal"><img border="0" src="//assets.pinterest.com/images/PinExt.png" title="Pin It" /></a>
        
    </div>
    <nav class="newPagination row">

   <div class="nextPrev"> 	
	<div class="older"> <a href="https://blog.thecurrent.org/2019/03/minneapolis-record-label-forged-artifacts-is-creating-community-through-cassettes/" rel="prev"><span>&lsaquo; Older</span> <i>Minneapolis record label Forged Artifacts is creating community through cassettes</i></a> </div>		
	</div>
	</nav>


            <div id="comments">
		    
<div id="disqus_thread">
    </div>

<script type="text/javascript">
var disqus_url = 'https://blog.thecurrent.org/2019/03/celebrating-prince-your-april-guide-to-events-in-the-twin-cities/';
var disqus_identifier = '36492 http://blog.thecurrent.org/?p=36492';
var disqus_container_id = 'disqus_thread';
var disqus_shortname = 'currentmpr';
var disqus_title = "Celebrating Prince: Your April guide to events in the Twin Cities";
var disqus_config_custom = window.disqus_config;
var disqus_config = function () {
    /*
    All currently supported events:
    onReady: fires when everything is ready,
    onNewComment: fires when a new comment is posted,
    onIdentify: fires when user is authenticated
    */
    
    
    this.language = '';
        this.callbacks.onReady.push(function () {

        // sync comments in the background so we don't block the page
        var script = document.createElement('script');
        script.async = true;
        script.src = '?cf_action=sync_comments&post_id=36492';

        var firstScript = document.getElementsByTagName('script')[0];
        firstScript.parentNode.insertBefore(script, firstScript);
    });
    
    if (disqus_config_custom) {
        disqus_config_custom.call(this);
    }
};

(function() {
    var dsq = document.createElement('script'); dsq.type = 'text/javascript';
    dsq.async = true;
    dsq.src = '//' + disqus_shortname + '.disqus.com/embed.js';
    (document.getElementsByTagName('head')[0] || document.getElementsByTagName('body')[0]).appendChild(dsq);
})();
</script>

		    </div>
			</article>

<aside class='adaptTarget adaptSmall' data-adapt="featureAds" id='sideRail'></aside>

			</section>
    	</div><!--end div.contentRail-->
	</div><!--end div@main-->

</div><!--end div.row#theCurrent-->


    <footer id="MPResponsiveFooter">             <div id="MPRFooterInnerWrapper">                 <div class="row">                     <div class="three columns">                         <div id="MPRFooterLogo"></div>                     </div>                     <div class="nine columns" id='theCurrentFooterItems'>                         <ul>                             <li><a href="http://blog.thecurrent.org">Blog</a></li>                             <li><a href="http://www.thecurrent.org/collection/in-studio">The Current Sessions</a></li>                             <li><a href="http://www.thecurrent.org/collection/guitar-collection">Guitar Collection</a></li>                             <li><a href="http://www.thecurrent.org/collection/interviews">Interviews</a></li>                             <li><a href="http://www.thecurrent.org/collection/musicheads">Musicheads</a></li>                             <li><a href="http://www.thecurrent.org/collection/news">Music News</a></li>                             <li><a href="http://www.thecurrent.org/newsletter">Newsletter</a></li>                             <li><a href="http://www.thecurrent.org/programs/oake-and-riley/">Oake &amp; Riley in the Morning</a></li>                             <li><a href="http://www.thecurrent.org/about#hosts">On-air DJs/Hosts</a></li>                             <li><a href="http://www.thecurrent.org/playlist">Playlist</a></li>                             <li><a href="http://www.thecurrent.org/collection/policy-and-a-pint">Policy and a Pint</a></li>                             <li><a href="http://www.thecurrent.org/about#podcasts">Podcasts</a></li>                             <li><a href="http://www.thecurrent.org/programs">Programs</a></li>                             <li><a href="http://www.thecurrent.org/collection/reviews">Reviews</a></li>                             <li><a href="http://www.thecurrent.org/collection/rock-and-roll-book-club">Rock and Roll Book Club</a></li>                             <li><a href="http://www.thecurrent.org/collection/rock-the-garden">Rock the Garden</a></li>                             <li><a href="http://www.thecurrent.org/collection/theft-of-the-dial">Theft of the Dial</a></li>                             <li><a href="http://www.thecurrent.org/video">Video</a></li>                             <li><a href="http://www.thecurrent.org/collection/win">Win Stuff</a></li>                         </ul>                     </div>                     <div class="four columns">                         <ul>                             <li>                                 <h6><a href="http://minnesota.publicradio.org">Minnesota Public Radio</a></h6>                             </li>                             <li><a href="http://www.thecurrent.org/about">About</a></li>                             <li><a href="https://contribute.publicradio.org/contribute.php?refId=current&utm_campaign=membership_contribution&utm_medium=web_footer&utm_source=current&utm_content=&utm_term">Become a Member</a></li>                             <li><a href="http://www.prettygoodgoods.org/categories/12931-the-current">Shop</a></li>                             <li><a href="http://minnesota.publicradio.org/about/site/terms/">Terms of use</a></li>                             <li><a href="http://minnesota.publicradio.org/about/site/privacy/">Your privacy rights</a></li>                             <li><a href="http://minnesota.publicradio.org/about/mpr/fcc/">Public Inspection Files</a></li>                             <li><a href="http://minnesota.publicradio.org/support/membership/fundraising-credentials.shtml">Fundraising Credentials</a></li>                             <li><a href="http://minnesota.publicradio.org/support/individual/volunteer.shtml">Volunteer</a></li>                         </ul>                     </div>                 </div>                 <div class="row">                     <div id="MPRFooterCopyright">                         Minnesota Public Radio &copy; 2017. All rights reserved.                     </div>                 </div>             </div>         </footer>
</div><!--end-#container-->

<script src="//common.publicradio.org//mpr/header/responsive/responsive.js" data-component="responsive"></script><script data-component="facebook">         if (jQuery('.fb-like:visible').length) {             (function(d, s, id) {                 var js, fjs = d.getElementsByTagName(s)[0];                 if (d.getElementById(id)) return;                 js = d.createElement(s);                 js.id = id;                 js.src = "//connect.facebook.net/en_US/all.js#xfbml=1&appId=115904101776300";                 fjs.parentNode.insertBefore(js, fjs);             }(document, 'script', 'facebook-jssdk'));         }     </script>
    <script type="text/javascript">
        var $blog_url = 'https://blog.thecurrent.org';
    </script>

        <script type="text/javascript">
        // <![CDATA[
        var disqus_shortname = 'currentmpr';
        (function () {
            var nodes = document.getElementsByTagName('span');
            for (var i = 0, url; i < nodes.length; i++) {
                if (nodes[i].className.indexOf('dsq-postid') != -1) {
                    nodes[i].parentNode.setAttribute('data-disqus-identifier', nodes[i].getAttribute('data-dsqidentifier'));
                    url = nodes[i].parentNode.href.split('#', 1);
                    if (url.length == 1) { url = url[0]; }
                    else { url = url[1]; }
                    nodes[i].parentNode.href = url + '#disqus_thread';
                }
            }
            var s = document.createElement('script');
            s.async = true;
            s.type = 'text/javascript';
            s.src = '//' + disqus_shortname + '.disqus.com/count.js';
            (document.getElementsByTagName('HEAD')[0] || document.getElementsByTagName('BODY')[0]).appendChild(s);
        }());
        // ]]>
        </script>
        <script type='text/javascript' src='https://kyigt1bcans3ofli94di0kch-wpengine.netdna-ssl.com/wp-content/themes/thecurrent/js/foundation_min.js?ver=1553788749'></script>
<script type='text/javascript' src='https://kyigt1bcans3ofli94di0kch-wpengine.netdna-ssl.com/wp-content/themes/thecurrent/js/modernizr_foundation.js?ver=1553788749'></script>
<script type='text/javascript' src='https://kyigt1bcans3ofli94di0kch-wpengine.netdna-ssl.com/wp-content/themes/thecurrent/js/app.js?ver=1553788749'></script>
<script type='text/javascript' src='https://kyigt1bcans3ofli94di0kch-wpengine.netdna-ssl.com/wp-content/themes/thecurrent/js/site.js?ver=1553788749'></script>
<script type='text/javascript' src='https://kyigt1bcans3ofli94di0kch-wpengine.netdna-ssl.com/wp-content/themes/mpr-shared-libs/javascripts/jquery-picture-min.js?ver=DEPLOY_VERSION'></script>
<script type='text/javascript' src='https://kyigt1bcans3ofli94di0kch-wpengine.netdna-ssl.com/wp-includes/js/wp-embed.min.js'></script>
	</body>
</html>
