<!DOCTYPE html>
<!--[if lt IE 7]><html class="no-js lt-ie9 lt-ie8 lt-ie7"  xmlns:fb="https://www.facebook.com/2008/fbml"  xmlns:og="http://ogp.me/ns#" lang="en-US"><![endif]-->
<!--[if IE 7]>	 <html class="no-js lt-ie9 lt-ie8"  xmlns:fb="https://www.facebook.com/2008/fbml"  xmlns:og="http://ogp.me/ns#" lang="en-US"><![endif]-->
<!--[if IE 8]>	 <html class="no-js lt-ie9"  xmlns:fb="https://www.facebook.com/2008/fbml"  xmlns:og="http://ogp.me/ns#" lang="en-US"><![endif]-->
<!--[if gt IE 8]><!--><html class="no-js"  xmlns:fb="https://www.facebook.com/2008/fbml"  xmlns:og="http://ogp.me/ns#" lang="en-US"> <!--<![endif]-->
	<head>
		<meta charset="UTF-8">
		<meta http-equiv="X-UA-Compatible" content="IE=edge,chrome=1">
		<title>Dwynell Roland on the community&#8217;s response to the death of George Floyd: &#8216;Police brutality should never exist&#8217; |  Local Current Blog | The Current from Minnesota Public Radio</title>
		<link rel="profile" href="http://gmpg.org/xfn/11">
		<link rel="pingback" href="https://blog.thecurrent.org/xmlrpc.php">
				<link rel="stylesheet" href="//common.publicradio.org/mpr/header/responsive/header.css?8-31-17" />
        <link rel="stylesheet" href="//common.publicradio.org/mpr/footer/responsive/footer.css" />
                                <link rel="shortcut icon" href="https://kyigt1bcans3ofli94di0kch-wpengine.netdna-ssl.com/wp-content/themes/thecurrent/images/favicon.ico" type="image/x-icon" />
        <link rel="apple-touch-icon" href="https://kyigt1bcans3ofli94di0kch-wpengine.netdna-ssl.com/wp-content/themes/thecurrent/images/touch-icon-iphone.png" />
        <link rel="apple-touch-icon" sizes="72x72" href="https://kyigt1bcans3ofli94di0kch-wpengine.netdna-ssl.com/wp-content/themes/thecurrent/images/touch-icon-ipad.png" />
        <link rel="apple-touch-icon" sizes="114x114" href="https://kyigt1bcans3ofli94di0kch-wpengine.netdna-ssl.com/wp-content/themes/thecurrent/images/touch-icon-iphone4.png" />
<!-- , , ,  -->
		    
 
<meta property="og:title" content="Dwynell Roland on the community&#8217;s response to the death of George Floyd: &#8216;Police brutality should never exist&#8217;">

<meta property="og:description" content="This past week on The Local Show, we heard from local artists who have been impacted by the killing of George Floyd. Minnesota rapper Dwynell Roland shared a message with The Current&#8217;s Local Show listeners on Sunday regarding this tragedy and the community&#8217;s response. Hey. This is Dwynell Roland. It&#8217;s a wild time. I would [&hellip;]">
<meta name="description" content="This past week on The Local Show, we heard from local artists who have been impacted by the killing of George Floyd. Minnesota rapper Dwynell Roland shared a message with The Current&#8217;s Local Show listeners on Sunday regarding this tragedy and the community&#8217;s response. Hey. This is Dwynell Roland. It&#8217;s a wild time. I would [&hellip;]">

<meta property="og:url" content="https://blog.thecurrent.org/2020/06/dwynell-roland-on-the-communitys-response-to-the-death-of-george-floyd-police-brutality-should-never-exist/">

<meta name="author" content="Sylvia Jennings">

<meta property="og:image" content="https://blog.thecurrent.org/wp-content/blogs.dir/9/files/2020/06/Dwynell-Roland-Rock-the-Garden.jpg">
<meta property="og:type" content="article">
<meta property="og:site_name" content="Local Current Blog | The Current from Minnesota Public Radio">


	
<meta name="mpr-collection" content="Contributors">
<meta name="WT.cg_n" content="The Current: Contributors">


<meta name="mpr-content-group" content="blog">
<meta name="viewport" content="width=device-width, initial-scale=1">
<link rel='dns-prefetch' href='//s.w.org' />
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/12.0.0-1\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/12.0.0-1\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/blog.thecurrent.org\/wp-includes\/js\/wp-emoji-release.min.js"}};
			/*! This file is auto-generated */
			!function(e,a,t){var r,n,o,i,p=a.createElement("canvas"),s=p.getContext&&p.getContext("2d");function c(e,t){var a=String.fromCharCode;s.clearRect(0,0,p.width,p.height),s.fillText(a.apply(this,e),0,0);var r=p.toDataURL();return s.clearRect(0,0,p.width,p.height),s.fillText(a.apply(this,t),0,0),r===p.toDataURL()}function l(e){if(!s||!s.fillText)return!1;switch(s.textBaseline="top",s.font="600 32px Arial",e){case"flag":return!c([127987,65039,8205,9895,65039],[127987,65039,8203,9895,65039])&&(!c([55356,56826,55356,56819],[55356,56826,8203,55356,56819])&&!c([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]));case"emoji":return!c([55357,56424,55356,57342,8205,55358,56605,8205,55357,56424,55356,57340],[55357,56424,55356,57342,8203,55358,56605,8203,55357,56424,55356,57340])}return!1}function d(e){var t=a.createElement("script");t.src=e,t.defer=t.type="text/javascript",a.getElementsByTagName("head")[0].appendChild(t)}for(i=Array("flag","emoji"),t.supports={everything:!0,everythingExceptFlag:!0},o=0;o<i.length;o++)t.supports[i[o]]=l(i[o]),t.supports.everything=t.supports.everything&&t.supports[i[o]],"flag"!==i[o]&&(t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&t.supports[i[o]]);t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&!t.supports.flag,t.DOMReady=!1,t.readyCallback=function(){t.DOMReady=!0},t.supports.everything||(n=function(){t.readyCallback()},a.addEventListener?(a.addEventListener("DOMContentLoaded",n,!1),e.addEventListener("load",n,!1)):(e.attachEvent("onload",n),a.attachEvent("onreadystatechange",function(){"complete"===a.readyState&&t.readyCallback()})),(r=t.source||{}).concatemoji?d(r.concatemoji):r.wpemoji&&r.twemoji&&(d(r.twemoji),d(r.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
	<link rel='stylesheet' id='wp-block-library-css'  href='https://kyigt1bcans3ofli94di0kch-wpengine.netdna-ssl.com/wp-includes/css/dist/block-library/style.min.css' type='text/css' media='all' />
<link rel='stylesheet' id='foundation-css'  href='https://kyigt1bcans3ofli94di0kch-wpengine.netdna-ssl.com/wp-content/themes/thecurrent/styles/foundation.min.css' type='text/css' media='all' />
<link rel='stylesheet' id='thecurrent-style-css'  href='https://kyigt1bcans3ofli94di0kch-wpengine.netdna-ssl.com/wp-content/themes/thecurrent/styles/current-style.css' type='text/css' media='all' />
<link rel='stylesheet' id='thecurrent-blog-less-css'  href='https://kyigt1bcans3ofli94di0kch-wpengine.netdna-ssl.com/wp-content/themes/thecurrent/styles/current-less.css' type='text/css' media='all' />
<script type='text/javascript' src='https://kyigt1bcans3ofli94di0kch-wpengine.netdna-ssl.com/wp-includes/js/jquery/jquery.js?ver=1.12.4-wp'></script>
<script type='text/javascript' src='https://kyigt1bcans3ofli94di0kch-wpengine.netdna-ssl.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=1.4.1'></script>
<link rel='https://api.w.org/' href='https://blog.thecurrent.org/wp-json/' />
<link rel="canonical" href="https://blog.thecurrent.org/2020/06/dwynell-roland-on-the-communitys-response-to-the-death-of-george-floyd-police-brutality-should-never-exist/" />
<link rel='shortlink' href='https://blog.thecurrent.org/?p=39069' />
<link rel="alternate" type="application/json+oembed" href="https://blog.thecurrent.org/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fblog.thecurrent.org%2F2020%2F06%2Fdwynell-roland-on-the-communitys-response-to-the-death-of-george-floyd-police-brutality-should-never-exist%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://blog.thecurrent.org/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fblog.thecurrent.org%2F2020%2F06%2Fdwynell-roland-on-the-communitys-response-to-the-death-of-george-floyd-police-brutality-should-never-exist%2F&#038;format=xml" />
<link rel="sitemap" href="https://blog.thecurrent.org/sitemap.xml" />
</head>
	<body class="post-template-default single single-post postid-39069 single-format-standard">

        <noscript data-component="google-tag-manager"><iframe src="//www.googletagmanager.com/ns.html?id=GTM-48R7" height="0" width="0" style="display:none;visibility:hidden"></iframe></noscript>
    <script data-component="google-tag-manager">
        (function(w, d, s, l, i) {
            w[l] = w[l] || [];
            w[l].push({
                'gtm.start': new Date().getTime(),
                event: 'gtm.js'
            });
            var f = d.getElementsByTagName(s)[0],
                j = d.createElement(s),
                dl = l != 'dataLayer' ? '&l=' + l : '';
            j.async = true;
            j.src =
                '//www.googletagmanager.com/gtm.js?id=' + i + dl;
            f.parentNode.insertBefore(j, f);
        })(window, document, 'script', 'dataLayer', 'GTM-48R7');
    </script>

<header id="MPResponsiveHeaderBand">
  <nav id="headerTop">
    <ul id="mainNav" class="collapse" title="Stations">
      <li class="mpr">
        <a title="Minnesota Public Radio" href="http://www.mpr.org/">
          <b>Minnesota Public Radio</b>
        </a>
      </li>
      <li class="js-mprnav">
        <span class="collapsedName js-mprnav-button">
          <b>Stations</b>
        </span>
        <ul class="js-mprnav-menu">
          <header class="nav-mobile-header">
            <div class="nav-cancelbutton js-mprnav-close">Cancel</div>
            <div style="clear:both;"></div>
          </header>
          <li class="news">
            <a title="Minnesota Public Radio News" href="http://www.mprnews.org/">
              <span class="station-title">News</span>
              <span class="mobile-title">MPR News
                <span>mprnews.org</span>
              </span>
            </a>
          </li>
          <li class="current">
            <a title="The Current from Minnesota Public Radio" href="http://www.thecurrent.org/">
              <span class="station-title">The Current</span>
              <span class="mobile-title">The Current
                <span>thecurrent.org</span>
              </span>
            </a>
          </li>
          <li class="classical">
            <a title="Classical Minnesota Public Radio" href="http://www.classicalmpr.org/">
              <span class="station-title">Classical</span>
              <span class="mobile-title">Classical MPR
                <span>classicalmpr.org</span>
              </span>
            </a>
          </li>
          <li class="nav-mpr">
            <a title="Minnesota Public Radio" href="http://www.mpr.org/">
              <span class="mobile-title">Minnesota Public Radio<span>mpr.org</span>
              </span>
            </a>
          </li>
        </ul>
      </li>
    </ul>
    <div id="rightNav">
      <ul id="secondaryNav" class="collapse" title="" style="overflow:hidden">
        <li class="js-mprnav">
          <span class="collapsedName js-mprnav-button">
            <b>MPR Information</b>
          </span>
          <div class="js-mprnav-menu">
            <header class="nav-mobile-header">
              <div class="nav-headertitle">MPR Information</div>
              <div class="nav-cancelbutton js-mprnav-close">Cancel</div>
              <div style="clear:both;"></div>
            </header>
            <ul id="secondaryNavWrapper">
              <li class="nav-give-mobile">
                <a href="https://support.mpr.org/current-web" class="giveNowHeaderLink">Give Now</a>
              </li>
              <li>
                <a href="http://archive.mprnews.org/">Archive</a>
              </li>
              <li>
                <a class="withSub" href="http://www.mpr.org/events/">Events</a>
                <div class="eventsSub">
                  <ul>
                    <li class="first">
                      <a href="http://minnesota.publicradio.org/events/tickets/">Tickets</a>
                    </li>
                    <li>
                      <a href="http://minnesota.publicradio.org/events/">Events Calendar</a>
                    </li>
                    <li>
                      <a href="http://www.publicradiocustomtravel.org/">MPR Custom Travel</a>
                    </li>
                  </ul>
                </div>
              </li>
              <li>
                <a href="https://www.publicmediamarket.org/collections/the-current">Shop</a>
              </li>
              <li>
                <a class="withSub" href="http://www.mpr.org/about/">About us</a>
                <div id="aboutSub">
                  <ul>
                    <li>
                      <a href="http://www.mpr.org/about/">Company Information</a>
                    </li>
                    <li>
                      <a href="http://www.mpr.org/listen/stations/">Stations</a>
                    </li>
                    <li>
                      <a href="http://www.publicinsightnetwork.org/">Public Insight Journalism</a>
                    </li>
                    <li>
                      <a href="http://www.mpr.org/contact/">Contact Info</a>
                    </li>
                    <li>
                      <a href="http://www.mpr.org/press/">Press Room</a>
                    </li>
                    <li>
                      <a href="http://www.mpr.org/about/people/">MPR People</a>
                    </li>
                    <li>
                      <a href="https://apmgcareers.org/">Career Opportunities</a>
                    </li>
                    <li>
                      <a href="http://www.mpr.org/about/relationships/">Partners</a>
                    </li>
                    <li>
                      <a href="http://www.mpr.org/about/relationships/">Educational Sponsors</a>
                    </li>
                    <li>
                      <a href="http://www.mpr.org/connect/mn4mpr/">Minnesotans for MPR</a>
                    </li>
                    <li>
                      <a href="http://www.mpr.org/about/facilities/towers/">Tower Rental</a>
                    </li>
                  </ul>
                </div>
              </li>
              <li>
                <a class="withSub" href="http://www.mpr.org/members/">Members</a>
                <div id="supportSub">
                  <ul>
                    <li>
                      <a href="http://www.mpr.org/members/sustainers/">Sustaining Membership</a>
                    </li>
                    <li>
                      <a href="http://www.mpr.org/support/more-ways-to-give/">More Ways to Give</a>
                    </li>
                    <li>
                      <a href="http://www.mpr.org/contact/">Contact Information</a>
                    </li>
                    <li>
                      <a class="giveNowHeaderLink" href="https://support.mpr.org/current-web">Become a Member</a>
                    </li>
                  </ul>
                </div>
            </li>
              <li class="nav-give nav-give-title">
                <a href="https://support.mpr.org/current-web" class="giveNowHeaderLink">Give Now</a>
              </li>
            </ul>
          
        </div></li>
      </ul>
      <form class="search-form js-mprnav" action="/search" method="get" name="search" id="searchForm">
        <span class="collapsedName js-mprnav-button"></span>
        <div class="nav-search js-mprnav-menu">
          <header class="nav-mobile-header">
            <div class="nav-headertitle">Search The Current</div>
            <div class="nav-cancelbutton js-mprnav-close">Cancel</div>
            <div style="clear:both;"></div>
          </header>
          <input class="searchbox empty" name="q" placeholder="Search The Current" type="text">
        </div>
      </form>
    </div>
  </nav>
</header>
	<div id="container">
<div class="row" id="theCurrent">

	<header class="four columns navRail">
  <nav id="logoWrapper">
    <a id="logo" href="/">
      <span class="visuallyhidden">The Current</span>
    </a>
    <a href="https://support.mpr.org/current-web" id="giveNow">
      Listener Supported · <span>Give now</span> ›
    </a>
  </nav>
  <a href="https://www.thecurrent.org/listen" id="listenLive" target="player" class="player-open js-open">Listen Live
    <span></span>
  </a>
  <a href="/request" id="requestSong">
    <b>Request a song</b>
    <span></span>
  </a>
  <a id="skip" href="#pjaxReplaceTarget" title="Skip to content" class="screen-reader-text"></a>
  <nav id="headerNavWrapper">
    <ul id="headerNav">
      <li id="streams">
  <h3><a name="streams"><span>More </span>Streams</a></h3>
  <div class="inner" data-parent="#streams">
    <ol id="streamsSub" class="subNav">
      <li>
        <h5><a href="https://www.thecurrent.org/local">Local Current</a></h5>
        <p>
          Minnesota Music<br>
          <a href="https://www.thecurrent.org/listen/local" target="player" class="listen player-open">Listen Live <span></span></a>  <a href="http://blog.thecurrent.org" class="blog">Blog ›</a>
        </p>
      </li>
      <li><h5><a href="https://www.thecurrent.org/rock-the-cradle">Rock The Cradle</a></h5>
        <p>
          Music for kids and their adults<br>
          <a href="https://www.thecurrent.org/listen/rock-the-cradle" target="player" class="listen player-open">Listen Live <span></span></a>
        </p>
      </li>
      <li><h5><a href="https://www.thecurrent.org/heartland">Radio Heartland</a></h5>
        <p>
          Acoustic, Americana and Roots<br>
          <a href="https://www.thecurrent.org/listen/heartland" target="player" class="listen player-open">Listen Live <span></span></a>
        </p>
      </li>
      <li><h5><a href="https://www.thecurrent.org/purple-current">Purple Current</a></h5>
        <p>
          Exploring the musical legacy of Prince and beyond<br>
          <a href="https://www.thecurrent.org/listen/purple-current" target="player" class="listen player-open">Listen Live <span></span></a>
        </p>
      </li>
    </ol>
  </div>
</li>

     
    
      <li id="about">
  <h3><a href="https://www.thecurrent.org/about">About</a></h3>
  <div class="inner" data-parent="#about">
    <ul id="aboutSub" class="subNav">
      <li><a href="https://www.thecurrent.org/about">About</a></li>
      <li><a href="https://www.thecurrent.org/about#where-to-hear">Where to hear</a></li>
      <li><a href="https://www.thecurrent.org/about/mobile">Mobile apps</a></li>
      <li><a href="https://www.thecurrent.org/programs">Programs</a></li>
      <li><a href="https://www.thecurrent.org/about#hosts">Hosts</a></li>
      <li><a href="https://www.thecurrent.org/about#music">Submit Your Music</a></li>
      <li><a href="https://www.publicmediamarket.org/collections/the-current">Shop</a></li>
      <li class="spacer"></li>
      <li><a href="https://www.facebook.com/TheCurrent">Facebook</a></li>
      <li><a href="https://plus.google.com/104446135620282090978/posts">Google+</a></li>
      <li><a href="http://instagram.com/thecurrent">Instagram</a></li>
      <li><a href="http://893thecurrent.tumblr.com">Tumblr</a></li>
      <li><a href="https://twitter.com/TheCurrent">Twitter</a></li>
      <li><a href="http://www.youtube.com/user/893TheCurrent?sub_confirmation=1">YouTube</a></li>
    </ul>
  </div>
</li>

    </ul>
  </nav>
  <div id="navDrops"></div>
</header>


	<div id="pjaxReplaceTarget" role="main">
	    <div class="twelve columns contentRail detail">
    	    <header class="localBlog">
	<h1><a href="https://blog.thecurrent.org">Local Current Blog</a></h1>
</header>
    	    <section class="content">
				

	<article class='entry-content'>
	    <header>
	       <h1>Dwynell Roland on the community&#8217;s response to the death of George Floyd: &#8216;Police brutality should never exist&#8217;</h1>
	    </header>

          <div class="row">
              <div class="byline eight columns">
                  by <span class="author">Sylvia Jennings</span> &middot;

                  <a href="https://blog.thecurrent.org/2020/06/03/" title="View more posts from June 3, 2020">
                      <time datetime="2020-06-03T10:04:39-05:00">June 3, 2020</time>
                  </a>
                </div>

              <div class="taxonomies eight columns">
                  <span class="tags"></span>
                  <span class="topics"><a href="https://blog.thecurrent.org/music-topics/dwynell-roland/" rel="tag">Dwynell Roland</a></span>
                  <span class="categories"><a href="https://blog.thecurrent.org/category/contributors/" rel="tag">Contributors</a></span>
                  <span class="comments_number"><span class="dsq-postid" data-dsqidentifier="39069 http://blog.thecurrent.org/?p=39069"><a href="#comments" class="no-comments">Add a comment</a></span></span>
              </div>
          </div>

		    		            		    <figure id="primaryImage" class="">

					<img width="630" height="420" src="https://kyigt1bcans3ofli94di0kch-wpengine.netdna-ssl.com/wp-content/blogs.dir/9/files/2020/06/Dwynell-Roland-Rock-the-Garden-630x420.jpg" class="attachment-large size-large wp-post-image" alt="" srcset="https://kyigt1bcans3ofli94di0kch-wpengine.netdna-ssl.com/wp-content/blogs.dir/9/files/2020/06/Dwynell-Roland-Rock-the-Garden-630x420.jpg 630w, https://kyigt1bcans3ofli94di0kch-wpengine.netdna-ssl.com/wp-content/blogs.dir/9/files/2020/06/Dwynell-Roland-Rock-the-Garden-602x401.jpg 602w, https://kyigt1bcans3ofli94di0kch-wpengine.netdna-ssl.com/wp-content/blogs.dir/9/files/2020/06/Dwynell-Roland-Rock-the-Garden-768x512.jpg 768w, https://kyigt1bcans3ofli94di0kch-wpengine.netdna-ssl.com/wp-content/blogs.dir/9/files/2020/06/Dwynell-Roland-Rock-the-Garden-300x200.jpg 300w, https://kyigt1bcans3ofli94di0kch-wpengine.netdna-ssl.com/wp-content/blogs.dir/9/files/2020/06/Dwynell-Roland-Rock-the-Garden-600x400.jpg 600w, https://kyigt1bcans3ofli94di0kch-wpengine.netdna-ssl.com/wp-content/blogs.dir/9/files/2020/06/Dwynell-Roland-Rock-the-Garden-738x492.jpg 738w, https://kyigt1bcans3ofli94di0kch-wpengine.netdna-ssl.com/wp-content/blogs.dir/9/files/2020/06/Dwynell-Roland-Rock-the-Garden.jpg 1200w" sizes="(max-width: 630px) 100vw, 630px" />                    <figcaption>
                        Dwynell Roland at Rock the Garden 2017. (Evan Frost/MPR)                    </figcaption>
            	</figure>
        
          <aside id="featureAds" class="advertisements adaptTarget adaptWide" data-adapt="featureAds">
            <div class='adaptSource'>
            <ul>
            <li class="advertisement">
                <h5>Sponsor</h5>
                <div class="ad multi" id="mpr-ad-1"></div>
            </li>
            <li class="advertisement">
                <h5>Sponsor</h5>
                <div class="ad" id="mpr-ad-2"></div>
            </li>
            </ul>
            </div>
        </aside>
		    <p><em>This past week on The Local Show, we heard from local artists who have been impacted by the killing of George Floyd. Minnesota rapper Dwynell Roland shared a message with The Current&#8217;s Local Show listeners on Sunday regarding this tragedy and the community&#8217;s response.</em></p> <p><audio src="http://play.publicradio.org/web/o/minnesota/the_current/features/2020/06/03/dwynelllocalshowstatement_20200603_128.mp3" controls="controls"></audio></p> <p>Hey. This is Dwynell Roland. It&#8217;s a wild time. I would have never thought that anything like this would have happened, especially in the Twin Cities, but we&#8217;re here. Also, with that being said, I think it&#8217;s eye-opening to a lot of people. A lot of people meaning people who aren&#8217;t of color, and really showing reality that these things happen to people of color in these communities. It&#8217;s wild to know places that you&#8217;ve seen, and used to drive past or be around, and they aren&#8217;t there anymore. I think that&#8217;s the biggest thing to me that is just wild, but I get it.</p> <p>It&#8217;s a tough time, man. Rest in peace to George Floyd. I just hope that a lot of people, at the end of the day, are able to see the big picture, and things can change, [like] police brutality of people of color, and not only that, but a feeling, a sense of unity, that we can overcome these things that happened in our community. Being around the Twin Cities, I think you&#8217;ve seen the protests and people helping to clean up. I think the media is showing a lot of the bad that&#8217;s going on, the rioting and etc., but there are a lot of people that are trying their best to come together, not only in the Twin Cities, but in the whole country. That, in itself, is a beautiful thing and a blessing, so I just hope that we can continue to be as one. It&#8217;s a crazy time, but it&#8217;s a time that we should be trying to dig deep, and learn, and really take away that things need to change. We need to move forward. We need to be a helping hand with everyone and everything, and just try to build on things of this nature, hoping that it never happens again. I think with protesting and all the stuff that has been happening, I think, moving forward, a lot of things may change. I really hope it does.</p> <p>Being in the Twin Cities is just wild. It&#8217;s just wild to see. It&#8217;s wild to see parts [of town] that you walk by and they&#8217;re not there anymore, you know? It&#8217;s been crazy living here and seeing everything, but I know deep down inside that the Twin Cities will get through this. I know deep down inside that America will get through this. I know deep down inside that we will build off of this, and hopefully we can maintain a sense of accountability to people who are doing this to people of color or people in general. Police brutality should never exist, and I think there&#8217;s a big picture, and there&#8217;s more steps that need to come in order to change that, but I feel that they are coming. For anyone that&#8217;s listening to this, thank you for being present in the community, if you&#8217;re helping the community, if you&#8217;re seeing your partner and sending out messages and checking on people, etc. Thank you to The Current and thank you to, like I said, everyone, because this is a tough time right now, and, more than ever, we need to lean on each other. As long as we all want to progress, and move up, and move forward, and want change, there will be that. I think, more than ever, this is eye-opening to a lot of people for that to happen. To everyone in the Twin Cities and listening right now, I love you guys. Keep fighting the fight. Things will change. It&#8217;s only a matter of time.</p> <p><em>Morning Show host Jill Riley also had a chance to connect with Roland on Monday to have a more in-depth discussion about his and his family&#8217;s experiences growing up in the Twin Cities, and his optimism for how the events following the death of George Floyd could cause this society to change for the better.</em></p> <p><audio src="http://play.publicradio.org/web/o/minnesota/the_current/features/2020/06/03/dwynellmorningshow2020_20200603_128.mp3" controls="controls"></audio></p> <p><em><strong>What have you witnessed in the community? Have you been out and about?</strong></em></p> <p>What a lot of people aren&#8217;t showing is that a lot of the people in the community are actually helping, and actually cleaning up, and trying to do their best to make sure things are stable. I think that a lot of people aren&#8217;t really seeing that, or something&#8217;s not showing that. The community really does care about their community, and there&#8217;s people in there that are really rebuilding, picking up, sweeping, and helping with these efforts. It&#8217;s wild.</p> <p>I was talking to my dad, and my dad grew up in South Minneapolis, He said that the last time he protested was for Rodney King. He says he hasn&#8217;t done this since then. He grew up around the corner from Cub Foods. It&#8217;s weird to see that spot that he moved around freely not there anymore. Everything is crazy, but I know that a lot of people in the community, and not even just in the community, but in the world, are starting to see things for what they are.</p> <p>It&#8217;s a rough time. It&#8217;s still hard for me to wrap my head around, knowing that it&#8217;s on our front doorstep, and seeing what I&#8217;ve been seeing, as far as the National Guard, and everything, everywhere. I know deep down that things are really in the scope of moving in the right manner, and just seeing a lot of people, who are not even people of color, but white people, really standing up and being side by side with people of color, and really trying to become better, and become a movement, and trying to make things better, is the best thing. I want to just say thank you to people who understand that. It&#8217;s been an ongoing thing, and now it&#8217;s starting to really pick up heat.</p> <p><em><strong>We had some developments over the weekend, one of them being that Minnesota Attorney General Keith Ellison will lead the criminal cases arising from the killing of George Floyd. You used the word &#8220;hope&#8221; when you were just talking, there. Does that give you hope? What is your biggest fear right now?</strong></em></p> <p>Yeah. With Keith running it, that gives me hope, or more hope. We&#8217;ve seen stuff like this before, where something that seems like a closed case isn&#8217;t like that, or something gets off, so until that happens, then I will really be down to see that. With Keith running it, I feel like he&#8217;ll do a great, great job.</p> <p>I guess I don&#8217;t have any fears, technically, because I&#8217;ve been living in this skin forever. I can say that I hope that people around are more aware about these situations, and the people that are know being brought in and seeing how this is a real world, and a totally different world that black people have to experience, and people of color in general, that I&#8217;m hoping that people who aren&#8217;t people of color are aware, and want to stand side by side with people who are fearful, who are going through problems, and just try to help, try to keep a balance, and try to move forward. I can only hope that after this things will move forward and we can come together, be together as one, and be a collective. It&#8217;s a tough time for a lot of people. It&#8217;s just sad knowing it was based in our community, and right at home. It&#8217;s crazy to see, but for those who are fearful, I will say, if you are someone who isn&#8217;t a person of color, make sure you check on that person, and make sure you help, because this is real life. It&#8217;s a real thing.</p> 
            

          <div id="socialShare" class="hide-on-mobile">
        <!-- facebook devilspawn -->
        <div class="fbLikeWrapper">
        <div class="fb-like" data-href="https://blog.thecurrent.org/2020/06/dwynell-roland-on-the-communitys-response-to-the-death-of-george-floyd-police-brutality-should-never-exist/" data-send="false" data-layout="button_count" data-width="100" data-show-faces="false" data-colorscheme="light"></div>
        </div>
        <!-- twitter tweet button -->
    <a href="https://twitter.com/share" class="twitter-share-button" data-via="TheCurrent" id='twitterShareButton'>Tweet</a>
    <script>
        var tElem = document.getElementById('twitterShareButton');
            if (tElem.offsetWidth !== 0 && tElem.offsetHeight !== 0){
                ! function (d, s, id) {
                    var js, fjs = d.getElementsByTagName(s)[0];
                    if (!d.getElementById(id)) {
                        js = d.createElement(s);
                        js.id = id;
                        js.src = "//platform.twitter.com/widgets.js";
                        fjs.parentNode.insertBefore(js, fjs);
                    }
                }(document, "script", "twitter-wjs");
            }
        </script>

        <g:plusone></g:plusone>
        <script type="text/javascript">
            window.___gcfg = {
            lang: 'en-US'
            };

            (function() {
            //even tho this is g+, we key in on twitter elem because this uses the weird g: namespaced elements that are not yet init'd
            var tElem = document.getElementById('twitterShareButton');
          if (tElem.offsetWidth !== 0 && tElem.offsetHeight !== 0){    
                var po = document.createElement('script'); po.type = 'text/javascript'; po.async = true;
                po.src = 'https://apis.google.com/js/plusone.js';
                var s = document.getElementsByTagName('script')[0]; s.parentNode.insertBefore(po, s);
            }
            })();
        </script>
        
          <script data-component="facebook">
           if (jQuery('.fb-like:visible').length){
               (function(d, s, id) {
                var js, fjs = d.getElementsByTagName(s)[0];
                if (d.getElementById(id)) return;
                js = d.createElement(s); js.id = id;
                js.src = "//connect.facebook.net/en_US/all.js#xfbml=1&appId=115904101776300";
                fjs.parentNode.insertBefore(js, fjs);
              }(document, 'script', 'facebook-jssdk'));
            }
          </script>

        <a href="http://pinterest.com/pin/create/button/?url=https%3A%2F%2Fblog.thecurrent.org%2F2020%2F06%2Fdwynell-roland-on-the-communitys-response-to-the-death-of-george-floyd-police-brutality-should-never-exist%2F&media=&description=Dwynell+Roland+on+the+community%26%238217%3Bs+response+to+the+death+of+George+Floyd%3A+%26%238216%3BPolice+brutality+should+never+exist%26%238217%3B" class="pin-it-button" count-layout="horizontal"><img border="0" src="//assets.pinterest.com/images/PinExt.png" title="Pin It" /></a>
        
    </div>
    <nav class="newPagination row">

   <div class="nextPrev"> 	
	<div class="older"> <a href="https://blog.thecurrent.org/2020/06/mally-on-the-killing-of-george-floyd/" rel="prev"><span>&lsaquo; Older</span> <i>MaLLy on the killing of George Floyd: &#8216;Something&#8217;s got to give&#8217;</i></a> </div>		
	</div>
	</nav>


            <div id="comments">
		    
<div id="disqus_thread">
    </div>

<script type="text/javascript">
var disqus_url = 'https://blog.thecurrent.org/2020/06/dwynell-roland-on-the-communitys-response-to-the-death-of-george-floyd-police-brutality-should-never-exist/';
var disqus_identifier = '39069 http://blog.thecurrent.org/?p=39069';
var disqus_container_id = 'disqus_thread';
var disqus_shortname = 'currentmpr';
var disqus_title = "Dwynell Roland on the community&#8217;s response to the death of George Floyd: &#8216;Police brutality should never exist&#8217;";
var disqus_config_custom = window.disqus_config;
var disqus_config = function () {
    /*
    All currently supported events:
    onReady: fires when everything is ready,
    onNewComment: fires when a new comment is posted,
    onIdentify: fires when user is authenticated
    */
    
    
    this.language = '';
        this.callbacks.onReady.push(function () {

        // sync comments in the background so we don't block the page
        var script = document.createElement('script');
        script.async = true;
        script.src = '?cf_action=sync_comments&post_id=39069';

        var firstScript = document.getElementsByTagName('script')[0];
        firstScript.parentNode.insertBefore(script, firstScript);
    });
    
    if (disqus_config_custom) {
        disqus_config_custom.call(this);
    }
};

(function() {
    var dsq = document.createElement('script'); dsq.type = 'text/javascript';
    dsq.async = true;
    dsq.src = '//' + disqus_shortname + '.disqus.com/embed.js';
    (document.getElementsByTagName('head')[0] || document.getElementsByTagName('body')[0]).appendChild(dsq);
})();
</script>

		    </div>
			</article>

<aside class='adaptTarget adaptSmall' data-adapt="featureAds" id='sideRail'></aside>

			</section>
    	</div><!--end div.contentRail-->
	</div><!--end div@main-->

	<aside class="five columns" id="sideRail">
  <ul class="">
    <li class="advertisement">
	    <h5><a href="https://www.mpr.org/support/business/sponsor">Sponsor</a></h5>
      <div class="ad multi" id="mpr-ad-1"></div>
    </li>

    <li class="advertisement">
      <h5><a href="https://www.mpr.org/support/business/sponsor">Sponsor</a></h5>
      <div class="ad" id="mpr-ad-2"></div>
    </li>

    <li class="legacy-logo">
	  <a href="https://www.mpr.org/public/legacy-amendment-projects">
	    <img alt="Supported by Minnesota Legacy Amendment Arts and Cultural Heitage Fund" src="https://kyigt1bcans3ofli94di0kch-wpengine.netdna-ssl.com/wp-content/themes/thecurrent/images/legacy.png" >
	  </a>
	</li>
    
    <li class="advertisement">
      <div id="commerce-ad"></div>
    </li>
  </ul>
</aside>


</div><!--end div.row#theCurrent-->


<footer id="MPResponsiveFooter">
  <div id="MPRFooterInnerWrapper">
    <div class="row">
      <div class="three columns">
        <div id="MPRFooterLogo"></div>
      </div>
      <div class="nine columns" id="theCurrentFooterItems">
        <ul>
          <li>
            <a href="/feature/2018/01/21/download-the-current-app">The Current app</a>
          </li>
          <li>
            <a href="http://blog.thecurrent.org?footer">Blog</a>
          </li>
          <li>
            <a href="/collection/current-sessions">The Current Sessions</a>
          </li>
          <li>
            <a href="/programs/chart-show">The Chart Show</a>
          </li>
          <li>
            <a href="/collection/930-coffee-break">Coffee Break</a>
          </li>
          <li>
            <a href="/collection/the-currents-guitar-collection">Guitar Collection</a>
          </li>
          <li>
            <a href="/collection/interviews">Interviews</a>
          </li>
          <li>
            <a href="/collection/march-music-madness">March Music Madness</a>
          </li>
          <li>
            <a href="/collection/microshows">MicroShows</a>
          </li>
          <li>
            <a href="/collection/musicheads">Musicheads</a>
          </li>
          <li>
            <a href="/collection/music-news">Music News</a>
          </li>
          <li>
            <a href="/newsletter">Newsletters</a>
          </li>
          <li>
            <a href="/programs/the-current-morning-show">The Current Morning Show</a>
          </li>
          <li>
            <a href="/about#hosts">On-air DJs/Hosts</a>
          </li>
          <li>
            <a href="/collection/music-on-tv">Music on TV</a>
          </li>
          <li>
            <a href="/playlist">Playlist</a>
          </li>
          <li>
            <a href="/collection/policy-and-a-pint">Policy and a Pint</a>
          </li>
          <li>
            <a href="/about#podcasts">Podcasts</a>
          </li>
          <li>
            <a href="/programs">Programs</a>
          </li>
          <li>
            <a href="/collection/reviews">Reviews</a>
          </li>
          <li>
            <a href="/collection/rock-and-roll-book-club">Rock and Roll Book Club</a>
          </li>
          <li>
            <a href="/collection/rock-the-garden">Rock the Garden</a>
          </li>
          <li>
            <a href="/collection/theft-of-the-dial">Theft of the Dial</a>
          </li>
          <li>
            <a href="/collection/top89">Top 89</a>
          </li>
          <li>
            <a href="/collection/giveaways">Win Stuff</a>
          </li>
        </ul>
      </div>
      <div class="four columns mprFooter">
          <ul>
            <li>
              <a href="http://www.mpr.org/">Minnesota Public Radio - 89.3 The Current</a>
            </li>
            <li>
              <a href="/about">About</a>
            </li>
            <li>
              <a href="https://support.mpr.org/current-web">Become a Member</a>
            </li>
            <li>
              <a href="https://www.mpr.org/contact">Contact Us</a>
            </li>
            <li>
              <a href="https://www.publicmediamarket.org/collections/the-current">Shop</a>
            </li>
            <li>
              <a href="https://www.americanpublicmedia.org/terms/">Terms of use</a>
            </li>
            <li>
              <a href="https://www.americanpublicmedia.org/privacy/">Your privacy rights</a>
            </li>
            <li>
              <a href="http://www.mpr.org/support/fundraising-credentials">Fundraising Credentials</a>
            </li>
            <li>
              <a href="http://www.mpr.org/volunteer">Volunteer</a>
            </li>
            <li>
              <a href="https://www.mpr.org/station-outages?the-current"> Station Outage Information</a>
            </li>
          </ul>
      </div>
    </div>
    <div class="row">
      <div class="mprFooter" id="MPRFooterCopyright">
        © 2020 Minnesota Public Radio. All rights reserved.
      </div>
    </div>
  </div>
</footer>
</div><!--end-#container-->


    <script type="text/javascript">
        var $blog_url = 'https://blog.thecurrent.org';
    </script>

        <script type="text/javascript">
        // <![CDATA[
        var disqus_shortname = 'currentmpr';
        (function () {
            var nodes = document.getElementsByTagName('span');
            for (var i = 0, url; i < nodes.length; i++) {
                if (nodes[i].className.indexOf('dsq-postid') != -1) {
                    nodes[i].parentNode.setAttribute('data-disqus-identifier', nodes[i].getAttribute('data-dsqidentifier'));
                    url = nodes[i].parentNode.href.split('#', 1);
                    if (url.length == 1) { url = url[0]; }
                    else { url = url[1]; }
                    nodes[i].parentNode.href = url + '#disqus_thread';
                }
            }
            var s = document.createElement('script');
            s.async = true;
            s.type = 'text/javascript';
            s.src = '//' + disqus_shortname + '.disqus.com/count.js';
            (document.getElementsByTagName('HEAD')[0] || document.getElementsByTagName('BODY')[0]).appendChild(s);
        }());
        // ]]>
        </script>
        <script type='text/javascript' src='https://kyigt1bcans3ofli94di0kch-wpengine.netdna-ssl.com/wp-content/themes/thecurrent/js/foundation_min.js?ver=1591197164'></script>
<script type='text/javascript' src='https://kyigt1bcans3ofli94di0kch-wpengine.netdna-ssl.com/wp-content/themes/thecurrent/js/modernizr_foundation.js?ver=1591197164'></script>
<script type='text/javascript' src='https://kyigt1bcans3ofli94di0kch-wpengine.netdna-ssl.com/wp-content/themes/thecurrent/js/app.js?ver=1591197164'></script>
<script type='text/javascript' src='https://kyigt1bcans3ofli94di0kch-wpengine.netdna-ssl.com/wp-content/themes/thecurrent/js/site.js?ver=1591197164'></script>
<script type='text/javascript' src='https://kyigt1bcans3ofli94di0kch-wpengine.netdna-ssl.com/wp-content/themes/mpr-shared-libs/javascripts/jquery-picture-min.js?ver=DEPLOY_VERSION'></script>
<script type='text/javascript' src='https://kyigt1bcans3ofli94di0kch-wpengine.netdna-ssl.com/wp-includes/js/wp-embed.min.js'></script>
	</body>
</html>
