<!DOCTYPE html>
<!--[if lt IE 7]><html class="no-js lt-ie9 lt-ie8 lt-ie7"  xmlns:fb="https://www.facebook.com/2008/fbml"  xmlns:og="http://ogp.me/ns#" lang="en-US"><![endif]-->
<!--[if IE 7]>	 <html class="no-js lt-ie9 lt-ie8"  xmlns:fb="https://www.facebook.com/2008/fbml"  xmlns:og="http://ogp.me/ns#" lang="en-US"><![endif]-->
<!--[if IE 8]>	 <html class="no-js lt-ie9"  xmlns:fb="https://www.facebook.com/2008/fbml"  xmlns:og="http://ogp.me/ns#" lang="en-US"><![endif]-->
<!--[if gt IE 8]><!--><html class="no-js"  xmlns:fb="https://www.facebook.com/2008/fbml"  xmlns:og="http://ogp.me/ns#" lang="en-US"> <!--<![endif]-->
	<head>
		<meta charset="UTF-8">
		<meta http-equiv="X-UA-Compatible" content="IE=edge,chrome=1">
		<title>Five years after Prince&#8217;s death, Paisley Park will open atrium for remembrance |  Local Current Blog | The Current from Minnesota Public Radio</title>
		<link rel="profile" href="http://gmpg.org/xfn/11">
		<link rel="pingback" href="https://blog.thecurrent.org/xmlrpc.php">
				<link rel="stylesheet" href="//common.publicradio.org/mpr/header/responsive/header.css?8-31-17" />
        <link rel="stylesheet" href="//common.publicradio.org/mpr/footer/responsive/footer.css" />
                                <link rel="shortcut icon" href="https://kyigt1bcans3ofli94di0kch-wpengine.netdna-ssl.com/wp-content/themes/thecurrent/images/favicon.ico" type="image/x-icon" />
        <link rel="apple-touch-icon" href="https://kyigt1bcans3ofli94di0kch-wpengine.netdna-ssl.com/wp-content/themes/thecurrent/images/touch-icon-iphone.png" />
        <link rel="apple-touch-icon" sizes="72x72" href="https://kyigt1bcans3ofli94di0kch-wpengine.netdna-ssl.com/wp-content/themes/thecurrent/images/touch-icon-ipad.png" />
        <link rel="apple-touch-icon" sizes="114x114" href="https://kyigt1bcans3ofli94di0kch-wpengine.netdna-ssl.com/wp-content/themes/thecurrent/images/touch-icon-iphone4.png" />
<!-- , , ,  -->
		    
 
<meta property="og:title" content="Five years after Prince&#8217;s death, Paisley Park will open atrium for remembrance">

<meta property="og:description" content="Paisley Park has announced that it will open the venue&#8217;s atrium for fans to visit, free of charge, and pay their respects to Prince on April 21 — which will mark five years since Prince&#8217;s tragic death. The atrium, a light-filled space at the heart of Paisley Park that was very special to Prince, will [&hellip;]">
<meta name="description" content="Paisley Park has announced that it will open the venue&#8217;s atrium for fans to visit, free of charge, and pay their respects to Prince on April 21 — which will mark five years since Prince&#8217;s tragic death. The atrium, a light-filled space at the heart of Paisley Park that was very special to Prince, will [&hellip;]">

<meta property="og:url" content="https://blog.thecurrent.org/2021/03/five-years-after-princes-death-paisley-park-will-open-atrium-for-remembrance/">

<meta name="author" content="Jay Gabler">

<meta property="og:image" content="https://blog.thecurrent.org/wp-content/blogs.dir/9/files/2016/10/image001.jpg">
<meta property="og:type" content="article">
<meta property="og:site_name" content="Local Current Blog | The Current from Minnesota Public Radio">


	
<meta name="mpr-collection" content="News">
<meta name="WT.cg_n" content="The Current: News">


<meta name="mpr-content-group" content="blog">
<meta name="viewport" content="width=device-width, initial-scale=1">
<link rel='dns-prefetch' href='//s.w.org' />
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/13.0.1\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/13.0.1\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/blog.thecurrent.org\/wp-includes\/js\/wp-emoji-release.min.js"}};
			!function(e,a,t){var n,r,o,i=a.createElement("canvas"),p=i.getContext&&i.getContext("2d");function s(e,t){var a=String.fromCharCode;p.clearRect(0,0,i.width,i.height),p.fillText(a.apply(this,e),0,0);e=i.toDataURL();return p.clearRect(0,0,i.width,i.height),p.fillText(a.apply(this,t),0,0),e===i.toDataURL()}function c(e){var t=a.createElement("script");t.src=e,t.defer=t.type="text/javascript",a.getElementsByTagName("head")[0].appendChild(t)}for(o=Array("flag","emoji"),t.supports={everything:!0,everythingExceptFlag:!0},r=0;r<o.length;r++)t.supports[o[r]]=function(e){if(!p||!p.fillText)return!1;switch(p.textBaseline="top",p.font="600 32px Arial",e){case"flag":return s([127987,65039,8205,9895,65039],[127987,65039,8203,9895,65039])?!1:!s([55356,56826,55356,56819],[55356,56826,8203,55356,56819])&&!s([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]);case"emoji":return!s([55357,56424,8205,55356,57212],[55357,56424,8203,55356,57212])}return!1}(o[r]),t.supports.everything=t.supports.everything&&t.supports[o[r]],"flag"!==o[r]&&(t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&t.supports[o[r]]);t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&!t.supports.flag,t.DOMReady=!1,t.readyCallback=function(){t.DOMReady=!0},t.supports.everything||(n=function(){t.readyCallback()},a.addEventListener?(a.addEventListener("DOMContentLoaded",n,!1),e.addEventListener("load",n,!1)):(e.attachEvent("onload",n),a.attachEvent("onreadystatechange",function(){"complete"===a.readyState&&t.readyCallback()})),(n=t.source||{}).concatemoji?c(n.concatemoji):n.wpemoji&&n.twemoji&&(c(n.twemoji),c(n.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
	<link rel='stylesheet' id='wp-block-library-css'  href='https://kyigt1bcans3ofli94di0kch-wpengine.netdna-ssl.com/wp-includes/css/dist/block-library/style.min.css' type='text/css' media='all' />
<link rel='stylesheet' id='foundation-css'  href='https://kyigt1bcans3ofli94di0kch-wpengine.netdna-ssl.com/wp-content/themes/thecurrent/styles/foundation.min.css' type='text/css' media='all' />
<link rel='stylesheet' id='thecurrent-style-css'  href='https://kyigt1bcans3ofli94di0kch-wpengine.netdna-ssl.com/wp-content/themes/thecurrent/styles/current-style.css' type='text/css' media='all' />
<link rel='stylesheet' id='thecurrent-blog-less-css'  href='https://kyigt1bcans3ofli94di0kch-wpengine.netdna-ssl.com/wp-content/themes/thecurrent/styles/current-less.css' type='text/css' media='all' />
<script type='text/javascript' src='https://kyigt1bcans3ofli94di0kch-wpengine.netdna-ssl.com/wp-includes/js/jquery/jquery.min.js?ver=3.5.1' id='jquery-core-js'></script>
<script type='text/javascript' src='https://kyigt1bcans3ofli94di0kch-wpengine.netdna-ssl.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=3.3.2' id='jquery-migrate-js'></script>
<link rel="https://api.w.org/" href="https://blog.thecurrent.org/wp-json/" /><link rel="alternate" type="application/json" href="https://blog.thecurrent.org/wp-json/wp/v2/posts/39711" /><link rel="canonical" href="https://blog.thecurrent.org/2021/03/five-years-after-princes-death-paisley-park-will-open-atrium-for-remembrance/" />
<link rel='shortlink' href='https://blog.thecurrent.org/?p=39711' />
<link rel="alternate" type="application/json+oembed" href="https://blog.thecurrent.org/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fblog.thecurrent.org%2F2021%2F03%2Ffive-years-after-princes-death-paisley-park-will-open-atrium-for-remembrance%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://blog.thecurrent.org/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fblog.thecurrent.org%2F2021%2F03%2Ffive-years-after-princes-death-paisley-park-will-open-atrium-for-remembrance%2F&#038;format=xml" />
<link rel="sitemap" href="https://blog.thecurrent.org/sitemap.xml" />
</head>
	<body class="post-template-default single single-post postid-39711 single-format-standard">

        <noscript data-component="google-tag-manager"><iframe src="//www.googletagmanager.com/ns.html?id=GTM-48R7" height="0" width="0" style="display:none;visibility:hidden"></iframe></noscript>
    <script data-component="google-tag-manager">
        (function(w, d, s, l, i) {
            w[l] = w[l] || [];
            w[l].push({
                'gtm.start': new Date().getTime(),
                event: 'gtm.js'
            });
            var f = d.getElementsByTagName(s)[0],
                j = d.createElement(s),
                dl = l != 'dataLayer' ? '&l=' + l : '';
            j.async = true;
            j.src =
                '//www.googletagmanager.com/gtm.js?id=' + i + dl;
            f.parentNode.insertBefore(j, f);
        })(window, document, 'script', 'dataLayer', 'GTM-48R7');
    </script>

<header id="MPResponsiveHeaderBand">
  <nav id="headerTop">
    <ul id="mainNav" class="collapse" title="Stations">
      <li class="mpr">
        <a title="Minnesota Public Radio" href="http://www.mpr.org/">
          <b>Minnesota Public Radio</b>
        </a>
      </li>
      <li class="js-mprnav">
        <span class="collapsedName js-mprnav-button">
          <b>Stations</b>
        </span>
        <ul class="js-mprnav-menu">
          <header class="nav-mobile-header">
            <div class="nav-cancelbutton js-mprnav-close">Cancel</div>
            <div style="clear:both;"></div>
          </header>
          <li class="news">
            <a title="Minnesota Public Radio News" href="http://www.mprnews.org/">
              <span class="station-title">News</span>
              <span class="mobile-title">MPR News
                <span>mprnews.org</span>
              </span>
            </a>
          </li>
          <li class="current">
            <a title="The Current from Minnesota Public Radio" href="http://www.thecurrent.org/">
              <span class="station-title">The Current</span>
              <span class="mobile-title">The Current
                <span>thecurrent.org</span>
              </span>
            </a>
          </li>
          <li class="classical">
            <a title="Classical Minnesota Public Radio" href="http://www.classicalmpr.org/">
              <span class="station-title">Classical</span>
              <span class="mobile-title">Classical MPR
                <span>classicalmpr.org</span>
              </span>
            </a>
          </li>
          <li class="nav-mpr">
            <a title="Minnesota Public Radio" href="http://www.mpr.org/">
              <span class="mobile-title">Minnesota Public Radio<span>mpr.org</span>
              </span>
            </a>
          </li>
        </ul>
      </li>
    </ul>
    <div id="rightNav">
      <ul id="secondaryNav" class="collapse" title="" style="overflow:hidden">
        <li class="js-mprnav">
          <span class="collapsedName js-mprnav-button">
            <b>MPR Information</b>
          </span>
          <div class="js-mprnav-menu">
            <header class="nav-mobile-header">
              <div class="nav-headertitle">MPR Information</div>
              <div class="nav-cancelbutton js-mprnav-close">Cancel</div>
              <div style="clear:both;"></div>
            </header>
            <ul id="secondaryNavWrapper">
              <li class="nav-give-mobile">
                <a href="https://support.mpr.org/current-web" class="giveNowHeaderLink">Give Now</a>
              </li>
              <li>
                <a href="http://archive.mprnews.org/">Archive</a>
              </li>
              <li>
                <a class="withSub" href="http://www.mpr.org/events/">Events</a>
                <div class="eventsSub">
                  <ul>
                    <li class="first">
                      <a href="http://minnesota.publicradio.org/events/tickets/">Tickets</a>
                    </li>
                    <li>
                      <a href="http://minnesota.publicradio.org/events/">Events Calendar</a>
                    </li>
                    <li>
                      <a href="http://www.publicradiocustomtravel.org/">MPR Custom Travel</a>
                    </li>
                  </ul>
                </div>
              </li>
              <li>
                <a href="https://www.publicmediamarket.org/collections/the-current">Shop</a>
              </li>
              <li>
                <a class="withSub" href="http://www.mpr.org/about/">About us</a>
                <div id="aboutSub">
                  <ul>
                    <li>
                      <a href="http://www.mpr.org/about/">Company Information</a>
                    </li>
                    <li>
                      <a href="http://www.mpr.org/listen/stations/">Stations</a>
                    </li>
                    <li>
                      <a href="http://www.publicinsightnetwork.org/">Public Insight Journalism</a>
                    </li>
                    <li>
                      <a href="http://www.mpr.org/contact/">Contact Info</a>
                    </li>
                    <li>
                      <a href="http://www.mpr.org/press/">Press Room</a>
                    </li>
                    <li>
                      <a href="http://www.mpr.org/about/people/">MPR People</a>
                    </li>
                    <li>
                      <a href="https://apmgcareers.org/">Career Opportunities</a>
                    </li>
                    <li>
                      <a href="http://www.mpr.org/about/relationships/">Partners</a>
                    </li>
                    <li>
                      <a href="http://www.mpr.org/about/relationships/">Educational Sponsors</a>
                    </li>
                    <li>
                      <a href="http://www.mpr.org/connect/mn4mpr/">Minnesotans for MPR</a>
                    </li>
                    <li>
                      <a href="http://www.mpr.org/about/facilities/towers/">Tower Rental</a>
                    </li>
                  </ul>
                </div>
              </li>
              <li>
                <a class="withSub" href="http://www.mpr.org/members/">Members</a>
                <div id="supportSub">
                  <ul>
                    <li>
                      <a href="http://www.mpr.org/members/sustainers/">Sustaining Membership</a>
                    </li>
                    <li>
                      <a href="http://www.mpr.org/support/more-ways-to-give/">More Ways to Give</a>
                    </li>
                    <li>
                      <a href="http://www.mpr.org/contact/">Contact Information</a>
                    </li>
                    <li>
                      <a class="giveNowHeaderLink" href="https://support.mpr.org/current-web">Become a Member</a>
                    </li>
                  </ul>
                </div>
            </li>
              <li class="nav-give nav-give-title">
                <a href="https://support.mpr.org/current-web" class="giveNowHeaderLink">Give Now</a>
              </li>
            </ul>
          
        </div></li>
      </ul>
      <form class="search-form js-mprnav" action="/search" method="get" name="search" id="searchForm">
        <span class="collapsedName js-mprnav-button"></span>
        <div class="nav-search js-mprnav-menu">
          <header class="nav-mobile-header">
            <div class="nav-headertitle">Search The Current</div>
            <div class="nav-cancelbutton js-mprnav-close">Cancel</div>
            <div style="clear:both;"></div>
          </header>
          <input class="searchbox empty" name="q" placeholder="Search The Current" type="text">
        </div>
      </form>
    </div>
  </nav>
</header>
	<div id="container">
<div class="row" id="theCurrent">

	<header class="four columns navRail">
  <nav id="logoWrapper">
    <a id="logo" href="/">
      <span class="visuallyhidden">The Current</span>
    </a>
    <a href="https://support.mpr.org/current-web" id="giveNow">
      Listener Supported · <span>Give now</span> ›
    </a>
  </nav>
  <a href="https://www.thecurrent.org/listen" id="listenLive" target="player" class="player-open js-open">Listen Live
    <span></span>
  </a>
  <a href="/request" id="requestSong">
    <b>Request a song</b>
    <span></span>
  </a>
  <a id="skip" href="#pjaxReplaceTarget" title="Skip to content" class="screen-reader-text"></a>
  <nav id="headerNavWrapper">
    <ul id="headerNav">
      <li id="streams">
  <h3><a name="streams"><span>More </span>Streams</a></h3>
  <div class="inner" data-parent="#streams">
    <ol id="streamsSub" class="subNav">
      <li>
        <h5><a href="https://www.thecurrent.org/local">Local Current</a></h5>
        <p>
          Minnesota Music<br>
          <a href="https://www.thecurrent.org/listen/local" target="player" class="listen player-open">Listen Live <span></span></a>  <a href="http://blog.thecurrent.org" class="blog">Blog ›</a>
        </p>
      </li>
      <li><h5><a href="https://www.thecurrent.org/rock-the-cradle">Rock The Cradle</a></h5>
        <p>
          Music for kids and their adults<br>
          <a href="https://www.thecurrent.org/listen/rock-the-cradle" target="player" class="listen player-open">Listen Live <span></span></a>
        </p>
      </li>
      <li><h5><a href="https://www.thecurrent.org/heartland">Radio Heartland</a></h5>
        <p>
          Acoustic, Americana and Roots<br>
          <a href="https://www.thecurrent.org/listen/heartland" target="player" class="listen player-open">Listen Live <span></span></a>
        </p>
      </li>
      <li><h5><a href="https://www.thecurrent.org/purple-current">Purple Current</a></h5>
        <p>
          Exploring the musical legacy of Prince and beyond<br>
          <a href="https://www.thecurrent.org/listen/purple-current" target="player" class="listen player-open">Listen Live <span></span></a>
        </p>
      </li>
    </ol>
  </div>
</li>

     
    
      <li id="about">
  <h3><a href="https://www.thecurrent.org/about">About</a></h3>
  <div class="inner" data-parent="#about">
    <ul id="aboutSub" class="subNav">
      <li><a href="https://www.thecurrent.org/about">About</a></li>
      <li><a href="https://www.thecurrent.org/about#where-to-hear">Where to hear</a></li>
      <li><a href="https://www.thecurrent.org/about/mobile">Mobile apps</a></li>
      <li><a href="https://www.thecurrent.org/programs">Programs</a></li>
      <li><a href="https://www.thecurrent.org/about#hosts">Hosts</a></li>
      <li><a href="https://www.thecurrent.org/about#music">Submit Your Music</a></li>
      <li><a href="https://www.publicmediamarket.org/collections/the-current">Shop</a></li>
      <li class="spacer"></li>
      <li><a href="https://www.facebook.com/TheCurrent">Facebook</a></li>
      <li><a href="https://plus.google.com/104446135620282090978/posts">Google+</a></li>
      <li><a href="http://instagram.com/thecurrent">Instagram</a></li>
      <li><a href="http://893thecurrent.tumblr.com">Tumblr</a></li>
      <li><a href="https://twitter.com/TheCurrent">Twitter</a></li>
      <li><a href="http://www.youtube.com/user/893TheCurrent?sub_confirmation=1">YouTube</a></li>
    </ul>
  </div>
</li>

    </ul>
  </nav>
  <div id="navDrops"></div>
</header>


	<div id="pjaxReplaceTarget" role="main">
	    <div class="twelve columns contentRail detail">
    	    <header class="localBlog">
	<h1><a href="https://blog.thecurrent.org">Local Current Blog</a></h1>
</header>
    	    <section class="content">
				

	<article class='entry-content'>
	    <header>
	       <h1>Five years after Prince&#8217;s death, Paisley Park will open atrium for remembrance</h1>
	    </header>

          <div class="row">
              <div class="byline eight columns">
                  by <span class="author">Jay Gabler</span> &middot;

                  <a href="https://blog.thecurrent.org/2021/03/23/" title="View more posts from March 23, 2021">
                      <time datetime="2021-03-23T11:49:54-05:00">March 23, 2021</time>
                  </a>
                </div>

              <div class="taxonomies eight columns">
                  <span class="tags"></span>
                  <span class="topics"><a href="https://blog.thecurrent.org/music-topics/prince/" rel="tag">Prince</a> <a href="https://blog.thecurrent.org/music-topics/paisley-park/" rel="tag">Paisley Park</a></span>
                  <span class="categories"><a href="https://blog.thecurrent.org/category/news/" rel="tag">News</a></span>
                  <span class="comments_number"><span class="dsq-postid" data-dsqidentifier="39711 http://blog.thecurrent.org/?p=39711"><a href="#comments" class="no-comments">Add a comment</a></span></span>
              </div>
          </div>

		    		            		    <figure id="primaryImage" class="">

					<img width="630" height="419" src="https://kyigt1bcans3ofli94di0kch-wpengine.netdna-ssl.com/wp-content/blogs.dir/9/files/2016/10/image001-630x419.jpg" class="attachment-large size-large wp-post-image" alt="Photo of the Atrium at Paisley Park. / Photo courtesy of Paisley Park NPG Records" loading="lazy" srcset="https://kyigt1bcans3ofli94di0kch-wpengine.netdna-ssl.com/wp-content/blogs.dir/9/files/2016/10/image001-630x419.jpg 630w, https://kyigt1bcans3ofli94di0kch-wpengine.netdna-ssl.com/wp-content/blogs.dir/9/files/2016/10/image001-602x400.jpg 602w, https://kyigt1bcans3ofli94di0kch-wpengine.netdna-ssl.com/wp-content/blogs.dir/9/files/2016/10/image001-768x511.jpg 768w, https://kyigt1bcans3ofli94di0kch-wpengine.netdna-ssl.com/wp-content/blogs.dir/9/files/2016/10/image001-300x199.jpg 300w, https://kyigt1bcans3ofli94di0kch-wpengine.netdna-ssl.com/wp-content/blogs.dir/9/files/2016/10/image001-600x399.jpg 600w, https://kyigt1bcans3ofli94di0kch-wpengine.netdna-ssl.com/wp-content/blogs.dir/9/files/2016/10/image001-1260x838.jpg 1260w, https://kyigt1bcans3ofli94di0kch-wpengine.netdna-ssl.com/wp-content/blogs.dir/9/files/2016/10/image001-738x491.jpg 738w, https://kyigt1bcans3ofli94di0kch-wpengine.netdna-ssl.com/wp-content/blogs.dir/9/files/2016/10/image001-1476x981.jpg 1476w" sizes="(max-width: 630px) 100vw, 630px" />                    <figcaption>
                        Courtesy Paisley Park NPG Records                    </figcaption>
            	</figure>
        
          <aside id="featureAds" class="advertisements adaptTarget adaptWide" data-adapt="featureAds">
            <div class='adaptSource'>
            <ul>
            <li class="advertisement">
                <h5>Sponsor</h5>
                <div class="ad multi" id="mpr-ad-1"></div>
            </li>
            <li class="advertisement">
                <h5>Sponsor</h5>
                <div class="ad" id="mpr-ad-2"></div>
            </li>
            </ul>
            </div>
        </aside>
		    <p>Paisley Park has announced that it will open the venue&#8217;s atrium for fans to visit, free of charge, and pay their respects to Prince on April 21 — which will mark five years since Prince&#8217;s tragic death.</p> <p>The atrium, a light-filled space at the heart of Paisley Park that was <a href="https://www.thecurrent.org/feature/2020/05/27/up-all-nite-prince-episode-one">very special to Prince</a>, will be open from 9 a.m. to 9 p.m.; while there will be no charge for admission, <a href="https://www.paisleypark.com/news/paisley-park-invites-fans-to-pay-respects-to-prince-on-the-fifth-anniversary-of-his-passing?utm_campaign=paisley&amp;utm_medium=markdown&amp;utm_source=homepage">reservations are required</a>. Fans will also be encouraged to leave memorial items outside the gates of Prince&#8217;s former home and studio, as they did spontaneously after Prince&#8217;s death when the entire perimeter fence was covered with art and memories.</p> <p>In a <a href="https://www.rollingstone.com/music/music-news/prince-paisley-park-event-fifth-anniversary-death-1145688/">statement</a>, Paisley Park director Alan Seiffert said, &#8220;Prince’s passing remains incomprehensible to all of us. We celebrate his life and legacy every day at Paisley Park, a place that Prince wanted to share with the world. So, on this day especially, we acknowledge the incredible force and inspiration Prince is in people’s lives and open up our doors for them to pay their respects.&#8221;</p> <p>The Current is also making plans to honor Prince next month, and will announcing details shortly.</p> 
            

          <div id="socialShare" class="hide-on-mobile">
        <!-- facebook devilspawn -->
        <div class="fbLikeWrapper">
        <div class="fb-like" data-href="https://blog.thecurrent.org/2021/03/five-years-after-princes-death-paisley-park-will-open-atrium-for-remembrance/" data-send="false" data-layout="button_count" data-width="100" data-show-faces="false" data-colorscheme="light"></div>
        </div>
        <!-- twitter tweet button -->
    <a href="https://twitter.com/share" class="twitter-share-button" data-via="TheCurrent" id='twitterShareButton'>Tweet</a>
    <script>
        var tElem = document.getElementById('twitterShareButton');
            if (tElem.offsetWidth !== 0 && tElem.offsetHeight !== 0){
                ! function (d, s, id) {
                    var js, fjs = d.getElementsByTagName(s)[0];
                    if (!d.getElementById(id)) {
                        js = d.createElement(s);
                        js.id = id;
                        js.src = "//platform.twitter.com/widgets.js";
                        fjs.parentNode.insertBefore(js, fjs);
                    }
                }(document, "script", "twitter-wjs");
            }
        </script>

        <g:plusone></g:plusone>
        <script type="text/javascript">
            window.___gcfg = {
            lang: 'en-US'
            };

            (function() {
            //even tho this is g+, we key in on twitter elem because this uses the weird g: namespaced elements that are not yet init'd
            var tElem = document.getElementById('twitterShareButton');
          if (tElem.offsetWidth !== 0 && tElem.offsetHeight !== 0){    
                var po = document.createElement('script'); po.type = 'text/javascript'; po.async = true;
                po.src = 'https://apis.google.com/js/plusone.js';
                var s = document.getElementsByTagName('script')[0]; s.parentNode.insertBefore(po, s);
            }
            })();
        </script>
        
          <script data-component="facebook">
           if (jQuery('.fb-like:visible').length){
               (function(d, s, id) {
                var js, fjs = d.getElementsByTagName(s)[0];
                if (d.getElementById(id)) return;
                js = d.createElement(s); js.id = id;
                js.src = "//connect.facebook.net/en_US/all.js#xfbml=1&appId=115904101776300";
                fjs.parentNode.insertBefore(js, fjs);
              }(document, 'script', 'facebook-jssdk'));
            }
          </script>

        <a href="http://pinterest.com/pin/create/button/?url=https%3A%2F%2Fblog.thecurrent.org%2F2021%2F03%2Ffive-years-after-princes-death-paisley-park-will-open-atrium-for-remembrance%2F&media=&description=Five+years+after+Prince%26%238217%3Bs+death%2C+Paisley+Park+will+open+atrium+for+remembrance" class="pin-it-button" count-layout="horizontal"><img border="0" src="//assets.pinterest.com/images/PinExt.png" title="Pin It" /></a>
        
    </div>
    <nav class="newPagination row">

   <div class="nextPrev"> 	
	<div class="older"> <a href="https://blog.thecurrent.org/2021/03/who-has-time-to-fake-it-yusra-j-on-how-she-got-into-music-and-why-shell-never-conform/" rel="prev"><span>&lsaquo; Older</span> <i>“Who has time to fake it?”: Yusra J on how she got into music and why she&#8217;ll never conform</i></a> </div>		
	</div>
	</nav>


            <div id="comments">
		    
<div id="disqus_thread">
    </div>

<script type="text/javascript">
var disqus_url = 'https://blog.thecurrent.org/2021/03/five-years-after-princes-death-paisley-park-will-open-atrium-for-remembrance/';
var disqus_identifier = '39711 http://blog.thecurrent.org/?p=39711';
var disqus_container_id = 'disqus_thread';
var disqus_shortname = 'currentmpr';
var disqus_title = "Five years after Prince&#8217;s death, Paisley Park will open atrium for remembrance";
var disqus_config_custom = window.disqus_config;
var disqus_config = function () {
    /*
    All currently supported events:
    onReady: fires when everything is ready,
    onNewComment: fires when a new comment is posted,
    onIdentify: fires when user is authenticated
    */
    
    
    this.language = '';
        this.callbacks.onReady.push(function () {

        // sync comments in the background so we don't block the page
        var script = document.createElement('script');
        script.async = true;
        script.src = '?cf_action=sync_comments&post_id=39711';

        var firstScript = document.getElementsByTagName('script')[0];
        firstScript.parentNode.insertBefore(script, firstScript);
    });
    
    if (disqus_config_custom) {
        disqus_config_custom.call(this);
    }
};

(function() {
    var dsq = document.createElement('script'); dsq.type = 'text/javascript';
    dsq.async = true;
    dsq.src = '//' + disqus_shortname + '.disqus.com/embed.js';
    (document.getElementsByTagName('head')[0] || document.getElementsByTagName('body')[0]).appendChild(dsq);
})();
</script>

		    </div>
			</article>

<aside class='adaptTarget adaptSmall' data-adapt="featureAds" id='sideRail'></aside>

			</section>
    	</div><!--end div.contentRail-->
	</div><!--end div@main-->

	<aside class="five columns" id="sideRail">
  <ul class="">
    <li class="advertisement">
	    <h5><a href="https://www.mpr.org/support/business/sponsor">Sponsor</a></h5>
      <div class="ad multi" id="mpr-ad-1"></div>
    </li>

    <li class="advertisement">
      <h5><a href="https://www.mpr.org/support/business/sponsor">Sponsor</a></h5>
      <div class="ad" id="mpr-ad-2"></div>
    </li>

    <li class="legacy-logo">
	  <a href="https://www.mpr.org/public/legacy-amendment-projects">
	    <img alt="Supported by Minnesota Legacy Amendment Arts and Cultural Heitage Fund" src="https://kyigt1bcans3ofli94di0kch-wpengine.netdna-ssl.com/wp-content/themes/thecurrent/images/legacy.png" >
	  </a>
	</li>
    
    <li class="advertisement">
      <div id="commerce-ad"></div>
    </li>
  </ul>
</aside>


</div><!--end div.row#theCurrent-->


<footer id="MPResponsiveFooter">
  <div id="MPRFooterInnerWrapper">
    <div class="row">
      <div class="three columns">
        <div id="MPRFooterLogo"></div>
      </div>
      <div class="nine columns" id="theCurrentFooterItems">
        <ul>
          <li>
            <a href="/feature/2018/01/21/download-the-current-app">The Current app</a>
          </li>
          <li>
            <a href="http://blog.thecurrent.org?footer">Blog</a>
          </li>
          <li>
            <a href="/collection/current-sessions">The Current Sessions</a>
          </li>
          <li>
            <a href="/programs/chart-show">The Chart Show</a>
          </li>
          <li>
            <a href="/collection/930-coffee-break">Coffee Break</a>
          </li>
          <li>
            <a href="/collection/the-currents-guitar-collection">Guitar Collection</a>
          </li>
          <li>
            <a href="/collection/interviews">Interviews</a>
          </li>
          <li>
            <a href="/collection/march-music-madness">March Music Madness</a>
          </li>
          <li>
            <a href="/collection/microshows">MicroShows</a>
          </li>
          <li>
            <a href="/collection/musicheads">Musicheads</a>
          </li>
          <li>
            <a href="/collection/music-news">Music News</a>
          </li>
          <li>
            <a href="/newsletter">Newsletters</a>
          </li>
          <li>
            <a href="/programs/the-current-morning-show">The Current Morning Show</a>
          </li>
          <li>
            <a href="/about#hosts">On-air DJs/Hosts</a>
          </li>
          <li>
            <a href="/collection/music-on-tv">Music on TV</a>
          </li>
          <li>
            <a href="/playlist">Playlist</a>
          </li>
          <li>
            <a href="/collection/policy-and-a-pint">Policy and a Pint</a>
          </li>
          <li>
            <a href="/about#podcasts">Podcasts</a>
          </li>
          <li>
            <a href="/programs">Programs</a>
          </li>
          <li>
            <a href="/collection/reviews">Reviews</a>
          </li>
          <li>
            <a href="/collection/rock-and-roll-book-club">Rock and Roll Book Club</a>
          </li>
          <li>
            <a href="/collection/rock-the-garden">Rock the Garden</a>
          </li>
          <li>
            <a href="/collection/theft-of-the-dial">Theft of the Dial</a>
          </li>
          <li>
            <a href="/collection/top89">Top 89</a>
          </li>
          <li>
            <a href="/collection/giveaways">Win Stuff</a>
          </li>
        </ul>
      </div>
      <div class="four columns mprFooter">
          <ul>
            <li>
              <a href="http://www.mpr.org/">Minnesota Public Radio - 89.3 The Current</a>
            </li>
            <li>
              <a href="/about">About</a>
            </li>
            <li>
              <a href="https://support.mpr.org/current-web">Become a Member</a>
            </li>
            <li>
              <a href="https://www.mpr.org/contact">Contact Us</a>
            </li>
            <li>
              <a href="https://www.publicmediamarket.org/collections/the-current">Shop</a>
            </li>
            <li>
              <a href="https://www.americanpublicmedia.org/terms/">Terms of use</a>
            </li>
            <li>
              <a href="https://www.americanpublicmedia.org/privacy/">Your privacy rights</a>
            </li>
            <li>
              <a href="http://www.mpr.org/support/fundraising-credentials">Fundraising Credentials</a>
            </li>
            <li>
              <a href="http://www.mpr.org/volunteer">Volunteer</a>
            </li>
            <li>
              <a href="https://www.mpr.org/station-outages?the-current"> Station Outage Information</a>
            </li>
          </ul>
      </div>
    </div>
    <div class="row">
      <div class="mprFooter" id="MPRFooterCopyright">
        © 2020 Minnesota Public Radio. All rights reserved.
      </div>
    </div>
  </div>
</footer>
</div><!--end-#container-->


    <script type="text/javascript">
        var $blog_url = 'https://blog.thecurrent.org';
    </script>

        <script type="text/javascript">
        // <![CDATA[
        var disqus_shortname = 'currentmpr';
        (function () {
            var nodes = document.getElementsByTagName('span');
            for (var i = 0, url; i < nodes.length; i++) {
                if (nodes[i].className.indexOf('dsq-postid') != -1) {
                    nodes[i].parentNode.setAttribute('data-disqus-identifier', nodes[i].getAttribute('data-dsqidentifier'));
                    url = nodes[i].parentNode.href.split('#', 1);
                    if (url.length == 1) { url = url[0]; }
                    else { url = url[1]; }
                    nodes[i].parentNode.href = url + '#disqus_thread';
                }
            }
            var s = document.createElement('script');
            s.async = true;
            s.type = 'text/javascript';
            s.src = '//' + disqus_shortname + '.disqus.com/count.js';
            (document.getElementsByTagName('HEAD')[0] || document.getElementsByTagName('BODY')[0]).appendChild(s);
        }());
        // ]]>
        </script>
        <script type='text/javascript' src='https://kyigt1bcans3ofli94di0kch-wpengine.netdna-ssl.com/wp-content/themes/thecurrent/js/foundation_min.js?ver=1616540511' id='thecurrent-blog-foundation-js'></script>
<script type='text/javascript' src='https://kyigt1bcans3ofli94di0kch-wpengine.netdna-ssl.com/wp-content/themes/thecurrent/js/modernizr_foundation.js?ver=1616540511' id='thecurrent-blog-modernizer-foundation-js'></script>
<script type='text/javascript' src='https://kyigt1bcans3ofli94di0kch-wpengine.netdna-ssl.com/wp-content/themes/thecurrent/js/app.js?ver=1616540511' id='thecurrent-blog-app-js'></script>
<script type='text/javascript' src='https://kyigt1bcans3ofli94di0kch-wpengine.netdna-ssl.com/wp-content/themes/thecurrent/js/site.js?ver=1616540511' id='thecurrent-blog-site-js'></script>
<script type='text/javascript' src='https://kyigt1bcans3ofli94di0kch-wpengine.netdna-ssl.com/wp-content/themes/mpr-shared-libs/javascripts/jquery-picture-min.js?ver=DEPLOY_VERSION' id='jquery-picture-js'></script>
<script type='text/javascript' src='https://kyigt1bcans3ofli94di0kch-wpengine.netdna-ssl.com/wp-includes/js/wp-embed.min.js' id='wp-embed-js'></script>
	</body>
</html>
